Browse Source

Fix horizon dependency

This commit moves horizon to requirements.txt.

horizon was added to upper-constraints in stable branches recently,
so installing from the tarball no longer works. upper-constraints
in stable branches picks up the right version of horizon, so there
is no need for the upper bound of the horizon version.

In addition, the link of the horizon tarball was not updated after
the stable branch was created. I don't know why it works for stable/stein
but I believe this commit mitigates the situation as the upper-constraints
file in the requirements repo picks up the right version of horizon.

This commit is proposed directly as the similar change in the master
branch happened as part of Django 1.11 drop [1].

In addition, ironic-ui tox.ini specified install_command with the
upper-constraints.txt. The contraints file is now specified in "deps"
section to follow the convention used widely in the OpenStack community.
doc/requirements.txt is cleanup and the runtime and test requirements
are now added to "deps" of the "docs" env to generate the module index
properly.

stable/stein only:
sphinx entry in test-requirements.txt did not match global-requirements.
This commit updates it to match the current global-requirements.

[1] https://review.opendev.org/#/c/700845/

Change-Id: I9a310446743cfe6bca5480455b91a7cd74da8785
(cherry picked from commit efa4927bb7)
tags/3.4.1^0
Akihiro Motoki 1 month ago
parent
commit
5c593fd34a
4 changed files with 11 additions and 7 deletions
  1. +4
    -1
      lower-constraints.txt
  2. +1
    -0
      requirements.txt
  3. +2
    -3
      test-requirements.txt
  4. +4
    -3
      tox.ini

+ 4
- 1
lower-constraints.txt View File

@@ -16,6 +16,7 @@ deprecation==2.0
django-appconf==1.0.2
django-babel==0.6.2
django-compressor==2.2
django-debreach==1.4.2
django-pyscss==2.0.2
Django==1.11.11
docutils==0.14
@@ -27,6 +28,7 @@ fixtures==3.0.0
flake8==2.5.5
futurist==1.6.0
hacking==0.12.0
horizon==15.0.0
idna==2.6
imagesize==1.0.0
iso8601==0.1.12
@@ -56,9 +58,10 @@ oslo.config==5.2.0
oslo.i18n==3.20.0
oslo.policy==1.34.0
oslo.serialization==2.25.0
oslo.upgradecheck==0.1.1
oslo.utils==3.36.0
oslotest==3.2.0
osprofiler==2.0.0
osprofiler==2.3.0
packaging==17.1
pbr==2.0.0
pep8==1.5.7


+ 1
- 0
requirements.txt View File

@@ -4,3 +4,4 @@

pbr!=2.1.0,>=2.0.0 # Apache-2.0
python-ironicclient>=2.3.0 # Apache-2.0
horizon>=15.0.0

+ 2
- 3
test-requirements.txt View File

@@ -12,11 +12,10 @@ testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

# this is required for the docs build jobs
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
# Include horizon as test requirement
http://tarballs.openstack.org/horizon/horizon-master.tar.gz#egg=horizon

# integration tests requirements
selenium>=2.50.1 # Apache-2.0


+ 4
- 3
tox.ini View File

@@ -5,7 +5,6 @@ envlist = py3,py27,pep8

[testenv]
usedevelop = True
install_command = pip install -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/stein} {opts} {packages}
setenv = VIRTUAL_ENV={envdir}
NOSE_WITH_OPENSTACK=1
NOSE_OPENSTACK_COLOR=1
@@ -13,8 +12,10 @@ setenv = VIRTUAL_ENV={envdir}
NOSE_OPENSTACK_YELLOW=0.025
NOSE_OPENSTACK_SHOW_ELAPSED=1
DJANGO_SETTINGS_MODULE=ironic_ui.test.settings
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/stein}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = {toxinidir}/manage.py test ironic_ui --settings=ironic_ui.test.settings --exclude-tag integration

[testenv:integration]


Loading…
Cancel
Save