Browse Source

Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: Idb45c6b09980c6850b1acf05a03c9be59fb254bc
changes/24/728724/3
zhangbailin 1 year ago
committed by Brin Zhang
parent
commit
296c8669a9
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 1
- 1
lower-constraints.txt View File

@ -32,7 +32,7 @@ futurist==1.2.0
gitdb==4.0.5
GitPython==3.1.2
greenlet==0.4.15
hacking==3.0.0
hacking==3.0.1
ifaddr==0.1.6
importlib-metadata==1.6.0
ironic-lib==4.3.0


+ 1
- 1
test-requirements.txt View File

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.0.0,<3.1.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
ddt>=1.0.1 # MIT
doc8>=0.6.0 # Apache-2.0


Loading…
Cancel
Save