Browse Source

Place upper bound on python-dracclient version

The idrac hardware type requires python-dracclient versions greater than
or equal to 1.3.0 and less than 2.0.0.

This is not a backport of a similar change which merged on the master
and stable/stein branches [1]. That change specifies python-dracclient
versions greater than or equal to 1.5.0 and less than 3.0.0 are
required.

Subsequently, a change which merged only on master modified the bounds
to greater than or equal to 3.0.0 and less than 4.0.0 [2].

[1] https://review.opendev.org/#/q/I5f6d6be53aec9d72e8ba5cfa436f12e01966f871
[2] https://review.opendev.org/#/c/634903/

Change-Id: If5b0c5b69f0f8759136051072c1ff53c6d86217d
(cherry picked from commit f78ccef3f5)
changes/54/664454/1
Richard Pioso 5 months ago
parent
commit
65a63c5fd8
2 changed files with 2 additions and 2 deletions
  1. 1
    1
      doc/source/admin/drivers/idrac.rst
  2. 1
    1
      driver-requirements.txt

+ 1
- 1
doc/source/admin/drivers/idrac.rst View File

@@ -22,7 +22,7 @@ Enabling
22 22
 All iDRAC drivers require the ``python-dracclient`` library to be installed,
23 23
 for example::
24 24
 
25
-    sudo pip install 'python-dracclient>=1.3.0'
25
+    sudo pip install 'python-dracclient>=1.3.0,<2.0.0'
26 26
 
27 27
 To enable the ``idrac`` hardware type, add the following to your
28 28
 ``/etc/ironic/ironic.conf``:

+ 1
- 1
driver-requirements.txt View File

@@ -12,7 +12,7 @@ python-scciclient>=0.6.0
12 12
 python-ilorest-library>=2.1.0
13 13
 hpOneView>=4.4.0
14 14
 UcsSdk==0.8.2.2
15
-python-dracclient>=1.3.0
15
+python-dracclient>=1.3.0,<2.0.0
16 16
 python-xclarityclient>=0.1.6
17 17
 
18 18
 # The CIMC drivers use the Cisco IMC SDK version 0.7.2 or greater

Loading…
Cancel
Save