Browse Source

Update test requirements

And fix a little pep8 issue (missing blank line).

Change-Id: I9d7809a5d1dc956d798c41af29054e5d9cd0b9cf
changes/32/758432/1
Riccardo Pittau 1 month ago
parent
commit
b0b8435bf8
2 changed files with 3 additions and 2 deletions
  1. +1
    -0
      ironic/tests/unit/common/test_neutron.py
  2. +2
    -2
      test-requirements.txt

+ 1
- 0
ironic/tests/unit/common/test_neutron.py View File

@@ -30,6 +30,7 @@ from ironic.tests.unit.db import base as db_base
from ironic.tests.unit.objects import utils as object_utils
from ironic.tests.unit import stubs


@mock.patch('ironic.common.keystone.get_service_auth', autospec=True,
return_value=mock.sentinel.sauth)
@mock.patch('ironic.common.keystone.get_auth', autospec=True,


+ 2
- 2
test-requirements.txt View File

@@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.0.1,<3.1.0 # Apache-2.0
hacking>=3.1.0,<4.0.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
ddt>=1.0.1 # MIT
doc8>=0.6.0 # Apache-2.0
@@ -15,7 +15,7 @@ psycopg2>=2.8.5 # LGPL/ZPL
testtools>=2.2.0 # MIT
WebTest>=2.0.27 # MIT
bashate>=0.5.1 # Apache-2.0
pycodestyle>=2.0.0,<2.6.0 # MIT
pycodestyle>=2.0.0,<2.7.0 # MIT
pysnmp>=4.4.12
flake8-import-order>=0.17.1 # LGPLv3
Pygments>=2.2.0 # BSD


Loading…
Cancel
Save