Browse Source

Update glance version

This patch will fix functionnal test by updating glance version
to 2.5

Change-Id: Icdad36fad58c01c15b61ad4310c8d96c5e8a4f37
Corentin Ardeois 2 years ago
parent
commit
4f19bfad3b
2 changed files with 11 additions and 1 deletions
  1. 1
    1
      test/functional/glanceTest.js
  2. 10
    0
      test/unit/helpers/data/glance.js

+ 1
- 1
test/functional/glanceTest.js View File

@@ -50,7 +50,7 @@ describe("Glance", () => {
50 50
   describe("version()", () => {
51 51
 
52 52
     const supportedApiVersions = [
53
-      new Version('2.4')
53
+      new Version('2.5')
54 54
     ];
55 55
 
56 56
     /**

+ 10
- 0
test/unit/helpers/data/glance.js View File

@@ -45,6 +45,16 @@ function rootResponse() {
45 45
       versions: [
46 46
         {
47 47
           status: "CURRENT",
48
+          id: "v2.5",
49
+          links: [
50
+            {
51
+              href: "http://192.168.99.99:9292/v2/",
52
+              rel: "self"
53
+            }
54
+          ]
55
+        },
56
+        {
57
+          status: "SUPPORTED",
48 58
           id: "v2.3",
49 59
           links: [
50 60
             {

Loading…
Cancel
Save