You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

72 lines
2.2 KiB

{
"name": "openstack-lib",
"version": "0.0.2",
"description": "JavaScript API library for OpenStack.",
"main": "dist/index.js",
"scripts": {
"configure-devstack": "babel-node ./configure-devstack.js",
"test": "npm run test:node",
"test:node": "nyc babel-node test/unit/run.js",
"test:browser": "karma start",
"posttest:node": "nyc check-coverage",
"functional-test": "npm run functional-test:node ; npm run functional-test:browser",
"functional-test:node": "nyc --dir cover/functional/node babel-node test/functional/run.js",
"functional-test:browser": "karma start --basePath test/functional/",
"lint": "eslint ./",
"build": "babel src -d dist && webpack",
"docs": "npm run jsdoc; (cd ./doc && make html)",
"jsdoc": "jsdoc -t node_modules/jsdoc-sphinx/template -d ./doc/source/jsdoc ./src"
},
"repository": {
"type": "git",
"url": "https://git.openstack.org/openstack/js-openstack-lib"
},
"keywords": [
"openstack"
],
"author": "OpenStack <openstack-dev@lists.openstack.org>",
"license": "Apache-2.0",
"homepage": "http://www.openstack.org/",
"dependencies": {
"@babel/runtime": "^7.0.0",
"isomorphic-fetch": "^2.2.1",
"loglevel": "^1.4.1",
"url-parse": "^1.1.3"
},
"devDependencies": {
"@babel/cli": "^7.0.0",
"@babel/core": "^7.0.0",
"@babel/node": "^7.0.0",
"@babel/plugin-transform-runtime": "^7.0.0",
"@babel/preset-env": "^7.0.0",
"@babel/register": "^7.0.0",
"babel-core": "^7.0.0-bridge.0",
"babel-eslint": "^10.1.0",
"babel-loader": "^8.1.0",
"babel-plugin-istanbul": "^6.0.0",
"babel-plugin-transform-inline-environment-variables": "^6.8.0",
"eslint": "^7.1.0",
"eslint-plugin-standard": "^4.0.1",
"fetch-mock": "^5.0.5",
"jasmine": "^3.5.0",
"js-yaml": "^3.14.0",
"jsdoc": "^3.4.0",
"jsdoc-sphinx": "0.0.6",
"json-loader": "^0.5.7",
"karma": "^5.0.9",
"karma-chrome-launcher": "^3.1.0",
"karma-cli": "^2.0.0",
"karma-coverage": "^2.0.2",
"karma-firefox-launcher": "^1.3.0",
"karma-jasmine": "^3.1.1",
"karma-webpack": "^4.0.2",
"nyc": "^15.0.1",
"webpack": "^4.43.0",
"webpack-cli": "^3.3.11",
"yaml-loader": "^0.6.0"
},
"files": [
"dist"
]
}