Browse Source

Updated from global requirements

Change-Id: Id96ab625240968e65878e25746b3a2644c30f1a8
changes/71/431871/17
OpenStack Proposal Bot 4 years ago
parent
commit
634c1cf4e8
3 changed files with 12 additions and 12 deletions
  1. +7
    -7
      requirements.txt
  2. +1
    -1
      setup.py
  3. +4
    -4
      test-requirements.txt

+ 7
- 7
requirements.txt View File

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.8 # Apache-2.0
pbr>=2.0.0 # Apache-2.0
Babel>=2.3.4 # BSD
croniter>=0.3.4 # MIT License
eventlet!=0.18.3,>=0.18.2 # MIT
@ -12,11 +12,11 @@ keystoneauth1>=2.18.0 # Apache-2.0
keystonemiddleware>=4.12.0 # Apache-2.0
oslo.config!=3.18.0,>=3.14.0 # Apache-2.0
oslo.concurrency>=3.8.0 # Apache-2.0
oslo.context>=2.9.0 # Apache-2.0
oslo.context>=2.12.0 # Apache-2.0
oslo.db>=4.15.0 # Apache-2.0
oslo.log>=3.11.0 # Apache-2.0
oslo.messaging>=5.14.0 # Apache-2.0
oslo.middleware>=3.0.0 # Apache-2.0
oslo.middleware>=3.10.0 # Apache-2.0
oslo.policy>=1.17.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.service>=1.10.0 # Apache-2.0
@ -24,20 +24,20 @@ oslo.versionedobjects>=1.17.0 # Apache-2.0
Paste # MIT
PasteDeploy>=1.5.0 # MIT
python-glanceclient>=2.5.0 # Apache-2.0
python-novaclient!=7.0.0,>=6.0.0 # Apache-2.0
python-novaclient>=7.1.0 # Apache-2.0
python-cinderclient!=1.7.0,!=1.7.1,>=1.6.0 # Apache-2.0
requests!=2.12.2,>=2.10.0 # Apache-2.0
requests!=2.12.2,!=2.13.0,>=2.10.0 # Apache-2.0
Routes!=2.0,!=2.1,!=2.3.0,>=1.12.3;python_version=='2.7' # MIT
Routes!=2.0,!=2.3.0,>=1.12.3;python_version!='2.7' # MIT
python-neutronclient>=5.1.0 # Apache-2.0
six>=1.9.0 # MIT
SQLAlchemy<1.1.0,>=1.0.10 # MIT
sqlalchemy-migrate>=0.9.6 # Apache-2.0
stevedore>=1.17.1 # Apache-2.0
stevedore>=1.20.0 # Apache-2.0
taskflow>=2.7.0 # Apache-2.0
WebOb>=1.6.0 # MIT
oslo.i18n>=2.1.0 # Apache-2.0
python-swiftclient>=3.2.0 # Apache-2.0
python-heatclient>=1.6.1 # Apache-2.0
python-karborclient>=0.1.1 # Apache-2.0
python-karborclient>=0.1.3 # Apache-2.0
abclient>=0.2.3 # Apache-2.0

+ 1
- 1
setup.py View File

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=1.8'],
setup_requires=['pbr>=2.0.0'],
pbr=True)

+ 4
- 4
test-requirements.txt View File

@ -2,12 +2,12 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=0.12.0,!=0.13.0,<0.14 # Apache-2.0
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage>=4.0 # Apache-2.0
croniter>=0.3.4 # MIT License
python-subunit>=0.0.18 # Apache-2.0/BSD
sphinx!=1.3b1,<1.4,>=1.2.1 # BSD
sphinx>=1.5.1 # BSD
oslosphinx>=4.7.0 # Apache-2.0
oslotest>=1.10.0 # Apache-2.0
taskflow>=2.7.0 # Apache-2.0
@ -16,9 +16,9 @@ testscenarios>=0.4 # Apache-2.0/BSD
testtools>=1.4.0 # MIT
python-swiftclient>=3.2.0 # Apache-2.0
python-glanceclient>=2.5.0 # Apache-2.0
python-novaclient!=7.0.0,>=6.0.0 # Apache-2.0
python-novaclient>=7.1.0 # Apache-2.0
python-cinderclient!=1.7.0,!=1.7.1,>=1.6.0 # Apache-2.0
python-karborclient>=0.1.1 # Apache-2.0
python-karborclient>=0.1.3 # Apache-2.0
python-neutronclient>=5.1.0 # Apache-2.0
python-heatclient>=1.6.1 # Apache-2.0
reno>=1.8.0 # Apache-2.0


Loading…
Cancel
Save