Browse Source

Update amqp and PyMySQL lower constraints

Newer versions of kombu rely on updated versions of amqp [0]. Keystone's
lower-constraints job is failing consistently across multiple branches
because it's referencing amqp 2.2.2 when we should be relying on a newer
version (5.0.0+).

You can verify this by using `pip3 check` with the lower-constraints tox
environment.

Without this patch, you'll likely see the test_notifications tests fail
with something like:

  ModuleNotFoundError: No module named 'vine.five'

Which spirals into subsequent failures mocking messaging drivers.

This commit also fixes the lower-constraint for PyMySQL.

keystone does not have any lower constraint for PyMySQL so the
latest version 0.10.0 is picked by the job which is failing [1]
In OpenStack, PyMySQL's upper constraint is 0.9.3. Version 0.10.0 is
not tested [2]. Let's add PyMySQL lower constraint also so that we test
lower-constraint job with correct lower version.

Both of these fixes were proposed separate reviews in newer branches,
but due to a circular failure, they're being proposed together. The
amqp fix fails lower-constraints jobs because the PyMySQL issue and vice
versa.

[0] https://github.com/celery/celery/issues/3547
[1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
[2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
Closes-Bug: #1888886
(cherry picked from commit c495defc2b)
(cherry picked from commit 12891a039f)
(cherry picked from commit b7c3458b6f)
(cherry picked from commit 255b6cdd70)
(cherry picked from commit 3de085b1eb)
(cherry picked from commit 300e79e93b)
(cherry picked from commit fb7d54543f)
(cherry picked from commit 32967a8105)
changes/74/748474/3
Lance Bragstad 2 years ago
parent
commit
56c95ce785
  1. 3
      lower-constraints.txt

3
lower-constraints.txt

@ -1,4 +1,4 @@
amqp==2.2.2
amqp==5.0.0
Babel==2.3.4
bashate==0.5.1
bcrypt==3.1.3
@ -50,6 +50,7 @@ python-ldap===3.0.0
pymongo===3.0.2
pysaml2==4.5.0
PyJWT==1.6.1
PyMySQL==0.7.6
python-keystoneclient==3.8.0
python-memcached==1.56;python_version=='2.7'
python-memcached==1.58;python_version>='3.4'

Loading…
Cancel
Save