Browse Source

Fix lower-constraint for PyMySQL

keystone does not have any lower constraint for PyMySQL so the
latest version 0.10.0 is picked by the job which is failing [1]
In OpenStack, PyMySQL upper constraint is .9.3 means that version
is tested not 0.10.0 [2] let's add PyMySQL lower constraint also
so that we test lower-constraint job with correct lower version.

[1]https://zuul.opendev.org/t/openstack/build/3077d96f4fff4b7985cb763d0635d471/log/job-output.txt#621
[2]https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L384

Change-Id: I3834b3b34641c006c70614d5331d292c41f8a346
Closes-Bug: #1888886
(cherry picked from commit 3de085b1eb)
(cherry picked from commit 300e79e93b)
changes/57/745757/1
Vishakha Agarwal 2 months ago
committed by Colleen Murphy
parent
commit
fb7d54543f
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      lower-constraints.txt

+ 1
- 0
lower-constraints.txt View File

@@ -50,6 +50,7 @@ python-ldap===3.0.0
pymongo===3.0.2
pysaml2==4.5.0
PyJWT==1.6.1
PyMySQL==0.7.6
python-keystoneclient==3.8.0
python-memcached==1.56;python_version=='2.7'
python-memcached==1.58;python_version>='3.4'


Loading…
Cancel
Save