Update lower-constraints versions

This updates lower constraints to versions that will work with py38 so
that when we move to running on focal nodes, which has py38 as its
default py3 runtime, the lower-constraints job will continue to pass.

It also cleans out some secondary requirements that are no longer needed
due to our direct dependencies being updated.

Linters are removed that are kept in the global requirements blacklist
as those are not version tracked and are not relevant for our
lower-constraints unit test runs.

Change-Id: I228212d8347a33a6bc2735a8506acffe58bee2ec
Signed-off-by: Sean McGinnis <sean.mcginnis@gmail.com>
changes/03/734803/1
Sean McGinnis 3 years ago
parent 94314329e9
commit 8915fabc38
No known key found for this signature in database
GPG Key ID: CE7EE4BFAF8D70C8
  1. 2
      doc/requirements.txt
  2. 25
      lower-constraints.txt
  3. 2
      setup.cfg
  4. 2
      test-requirements.txt

@ -14,5 +14,5 @@ betamax>=0.7.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
requests-mock>=1.2.0 # Apache-2.0
lxml!=3.7.0,>=3.4.1 # BSD
lxml>=4.2.0 # BSD
oauthlib>=0.6.2 # BSD

@ -1,62 +1,48 @@
alabaster==0.7.10
appdirs==1.4.3
Babel==2.8.0
bandit==1.1.0
betamax==0.7.0
certifi==2018.1.18
chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1
coverage==4.0
debtcollector==1.19.0
docutils==0.14
dulwich==0.19.0
entrypoints==0.3
extras==1.0.0
fixtures==3.0.0
future==0.16.0
gitdb2==2.0.3
GitPython==2.1.8
idna==2.6
imagesize==1.0.0
iso8601==0.1.11
Jinja2==2.10
linecache2==1.0.0
lxml==3.4.1
MarkupSafe==1.0
mccabe==0.2.1
lxml==4.2.0
mock==2.0.0
monotonic==1.4
mox3==0.25.0
netaddr==0.7.19
netifaces==0.10.6
oauthlib==0.6.2
openstack-requirements==1.2.0
os-client-config==1.29.0
os-service-types==1.2.0
oslo.config==5.2.0
oslo.i18n==3.20.0
oslo.utils==3.33.0
oslotest==3.2.0
packaging==17.1
Parsley==1.3
pbr==2.0.0
pep257==0.7.0
prettytable==0.7.2
Pygments==2.2.0
pykerberos==1.2.1
pyparsing==2.2.0
pyperclip==1.6.0
python-mimeparse==1.6.0
python-subunit==1.2.0
pytz==2018.3
PyYAML==3.12
reno==3.1.0
requests==2.14.2
requests-kerberos==0.8.0
requests-mock==1.2.0
requests==2.14.2
requestsexceptions==1.4.0
rfc3986==1.1.0
six==1.10.0
smmap2==2.0.3
snowballstemmer==1.2.1
stestr==1.0.0
stevedore==1.20.0
testrepository==0.0.20
@ -65,5 +51,4 @@ testtools==2.2.0
traceback2==1.4.0
unittest2==1.1.0
urllib3==1.22
voluptuous==0.11.1
wrapt==1.10.11

@ -30,7 +30,7 @@ packages =
kerberos =
requests-kerberos>=0.8.0 # ISC
saml2 =
lxml!=3.7.0,>=3.4.1 # BSD
lxml>=4.2.0 # BSD
oauth1 =
oauthlib>=0.6.2 # BSD
betamax =

@ -21,5 +21,5 @@ testresources>=2.0.0 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
PyYAML>=3.12 # MIT
requests-kerberos>=0.8.0 # ISC
lxml!=3.7.0,>=3.4.1 # BSD
lxml>=4.2.0 # BSD
oauthlib>=0.6.2 # BSD

Loading…
Cancel
Save