Browse Source

Fix multiple issues

Multiple issues combined to pass CI

1. drop tripleo-common-tempest-plugin

This is not needed plugin without any branches or releases. And wants Python 3
while we have Py2 for CentOS 7.

Original Change-Id: I9cab91b82941ea125b16d19e68722ce41a1f11f2
14:41 < hrw> is  tripleo-common-tempest-plugin your stuff?
14:43 <@EmilienM> yes and it does nothing. I thought we removed that?
14:43 <@EmilienM> apparently it's still here https://github.com/openstack/tripleo-common-tempest-plugin
14:43 <@EmilienM> we should burn it, weshay|ruck ^
14:44 < hrw> EmilienM: also fine to drop from train?
14:44 <@EmilienM> burn it everywhere you can
14:44 < hrw> THANKS
14:44 <@EmilienM> it has never been useful
14:44 <@EmilienM> and people who started it left
14:48 <@weshay|ruck> EmilienM, yup

2. Sensu: Remove ceph and process-checks plugins from client

The sensu image became unbuildable, failing to install the ceph plugin:

    Unable to resolve dependencies: sensu-plugins-ceph requires english (= 0.6.3)

This has happened because the author of the 'english' gem has seen fit
to publish a new 0.7.0 release, and 'yank' [1] all previous releases
from rubygems.

This change removes the ceph and process-checks plugins, which both
suffer from a dependency on the yanked english 0.6.3.

[1] https://rubygems.org/gems/english/versions/0.6.3

Original Change-Id: I9d34413fa10b5a2920aca60b08141bfaddcc7415
Closes-Bug: #1871600
(cherry picked from commit 818dc4d6ff)
(cherry picked from commit 2d1017be3f)

3. Use freezer queens releases

There are no freezer releases in Rocky, so these packages stayed on
master. This is now python 3 only, so fails to build. Pin to Queens
6.0.0 releases.

4. Pin elasticsearch gem to <7.6.0 in fluentd

Since the release of the elasticsearch 7.6.0 gem, the fluentd image
fails to build on Ubuntu due to a transitive dependency on faraday.

ERROR:  Error installing fluent-plugin-elasticsearch:
    faraday requires Ruby version >= 2.3.

Pin elasticsearch to <7.6.0.

Change-Id: I6200ed527244313107666753257f52d4b9305dd3
changes/17/724117/2
Marcin Juszkiewicz 2 months ago
committed by Mark Goddard
parent
commit
03212577ef
3 changed files with 4 additions and 9 deletions
  1. +1
    -0
      docker/fluentd/Dockerfile.j2
  2. +0
    -2
      docker/sensu/sensu-client/Dockerfile.j2
  3. +3
    -7
      kolla/common/config.py

+ 1
- 0
docker/fluentd/Dockerfile.j2 View File

@@ -67,6 +67,7 @@ RUN chmod 755 /usr/local/bin/kolla_extend_start
# Ruby.
{% set fluentd_plugins = [
'fluentd:"<1.9.0"',
'elasticsearch:"<7.6.0"',
'faraday:"~>0.15.4"',
'fluent-plugin-elasticsearch:4.0.0',
'fluent-plugin-grep',


+ 0
- 2
docker/sensu/sensu-client/Dockerfile.j2 View File

@@ -50,7 +50,6 @@ RUN echo '{{ image_name }} not yet available for {{ base_distro }}' \
# Let's cap them to the known major version that works with the ruby shipped on
# rhel/centos/oraclelinux (currently 2.0)
{% set sensu_plugins = [
'ceph:"~>1"',
'cpu-checks:"~>1"',
'disk-checks:"~>2"',
'dns:"~>1"',
@@ -68,7 +67,6 @@ RUN echo '{{ image_name }} not yet available for {{ base_distro }}' \
'network-checks:"~>2"',
'ntp:"~>1"',
'openstack:"~>1"',
'process-checks:"~>2"',
'rabbitmq:"~>3"',
'redis:"~>2"',
'uptime-checks:"~>1"',


+ 3
- 7
kolla/common/config.py View File

@@ -339,11 +339,11 @@ SOURCES = {
'freezer-api': {
'type': 'url',
'location': ('$tarballs_base/freezer-api/'
'freezer-api-master.tar.gz')},
'freezer-api-6.0.0.tar.gz')},
'freezer-base': {
'type': 'url',
'location': ('$tarballs_base/freezer/'
'freezer-master.tar.gz')},
'freezer-6.0.0.tar.gz')},
'glance-base': {
'type': 'url',
'location': ('$tarballs_base/glance/'
@@ -384,7 +384,7 @@ SOURCES = {
'horizon-plugin-freezer-web-ui': {
'type': 'url',
'location': ('$tarballs_base/freezer-web-ui/'
'freezer-web-ui-master.tar.gz')},
'freezer-web-ui-6.0.0.tar.gz')},
'horizon-plugin-heat-dashboard': {
'type': 'url',
'location': ('$tarballs_base/heat-dashboard/'
@@ -726,10 +726,6 @@ SOURCES = {
'type': 'url',
'location': ('$tarballs_base/telemetry-tempest-plugin/'
'telemetry_tempest_plugin-0.1.0.tar.gz')},
'tempest-plugin-tripleo-common': {
'type': 'url',
'location': ('$tarballs_base/tripleo-common-tempest-plugin/'
'tripleo-common-tempest-plugin-master.tar.gz')},
'tempest-plugin-trove': {
'type': 'url',
'location': ('$tarballs_base/trove-tempest-plugin/'


Loading…
Cancel
Save