Browse Source

Fixes fluentd for rocky

Pin fluentd version to 1.8.x

fluentd has dropped support for ruby 2.3 and below at the end of 2019.

1) https://www.fluentd.org/blog/drop-schedule-announcement-in-2019
2) https://github.com/fluent/fluentd/pull/2750

Closes-Bug: #1860701

Change-Id: I29f54dc94a6e49118ce15401017947c07ed3ca54
tags/7.1.0
Dincer Celik 1 month ago
parent
commit
107d154672
2 changed files with 8 additions and 0 deletions
  1. +3
    -0
      docker/fluentd/Dockerfile.j2
  2. +5
    -0
      releasenotes/notes/fluentd-pin-version-for-ruby-deprecation-000c7c4ab9e407ee.yaml

+ 3
- 0
docker/fluentd/Dockerfile.j2 View File

@@ -60,10 +60,13 @@ RUN chmod 755 /usr/local/bin/kolla_extend_start
{% block fluentd_plugins_install %}

{% if base_distro in ['debian', 'ubuntu'] %}
# NOTE(osmanlicilegi): fluentd has dropped support for ruby 2.3 and below at
# the end of 2019 so we need to pin its version to 1.8.x.
# NOTE(mgoddard): fluent-plugin-elasticsearch requires faraday, which from
# 0.16.0 depends on Ruby 2.3, but td-agent provides its own older version of
# Ruby.
{% set fluentd_plugins = [
'fluentd:"<1.9.0"',
'faraday:"~>0.15.4"',
'fluent-plugin-elasticsearch',
'fluent-plugin-grep',


+ 5
- 0
releasenotes/notes/fluentd-pin-version-for-ruby-deprecation-000c7c4ab9e407ee.yaml View File

@@ -0,0 +1,5 @@
---
fixes:
- |
Pin fluentd version to 1.8.x for rocky as fluentd has dropped
support for ruby 2.3 and below at the end of 2019.

Loading…
Cancel
Save