Browse Source

Fixes fluentd for rocky

Pin fluent-plugin-elasticsearch to 4.0.0

fluent-plugin-elasticsearch now requires at least ruby 2.3 which is
not possible to run on ubuntu/debian for rocky after
https://review.opendev.org/#/c/704040/

[1] https://rubygems.org/gems/fluent-plugin-elasticsearch/versions/4.0.0
[2] https://rubygems.org/gems/fluent-plugin-elasticsearch/versions/4.0.1

Closes-Bug: #1862522

Change-Id: I94695b03791b1028d528052d772fc302ab8080ee
tags/7.1.1
Dincer Celik 1 month ago
parent
commit
21dabe0bef
2 changed files with 6 additions and 1 deletions
  1. +1
    -1
      docker/fluentd/Dockerfile.j2
  2. +5
    -0
      releasenotes/notes/fluentd-pin-version-for-elasticsearch-plugin-11d66cf6fa689e86.yaml

+ 1
- 1
docker/fluentd/Dockerfile.j2 View File

@@ -68,7 +68,7 @@ RUN chmod 755 /usr/local/bin/kolla_extend_start
{% set fluentd_plugins = [
'fluentd:"<1.9.0"',
'faraday:"~>0.15.4"',
'fluent-plugin-elasticsearch',
'fluent-plugin-elasticsearch:4.0.0',
'fluent-plugin-grep',
'fluent-plugin-grok-parser:2.1.4',
'fluent-plugin-parser',


+ 5
- 0
releasenotes/notes/fluentd-pin-version-for-elasticsearch-plugin-11d66cf6fa689e86.yaml View File

@@ -0,0 +1,5 @@
---
fixes:
- |
Pin fluent-plugin-elasticsearch version to 4.0.0 which is the last
version that supports ruby below 2.3.

Loading…
Cancel
Save