Browse Source

Revert "openstack-base: pin setuptools < 46 to get horizon working"

This reverts commit ca8b615164.

This is to fix recent breakage caused by setuptools and virtualenv
incompatibilities.

Includes bifrost version bump to fix its building.

Change-Id: Ia6c415b18374cefa3f160229d1f58cb209df348e
Closes-Bug: #1893920
Depends-On: https://review.opendev.org/749576
changes/34/749534/6
Radosław Piliszek 3 weeks ago
parent
commit
326823c4d3
2 changed files with 1 additions and 6 deletions
  1. +0
    -5
      docker/openstack-base/Dockerfile.j2
  2. +1
    -1
      kolla/common/config.py

+ 0
- 5
docker/openstack-base/Dockerfile.j2 View File

@@ -414,11 +414,6 @@ RUN ln -s openstack-base-source/* /requirements \

ENV PATH /var/lib/kolla/venv/bin:$PATH

# FIXME(hrw): pyScss used by Horizon fails to work with setuptools >= 46
# it had last release in 2016 so probably no one will fix it.
# So we need to be sure that we get older version of setuptools.
RUN {{ macros.install_pip(['"setuptools<46"']) }}

RUN {{ macros.install_pip(openstack_base_pip_packages | customizable("pip_packages")) }}

{% endif %}


+ 1
- 1
kolla/common/config.py View File

@@ -323,7 +323,7 @@ SOURCES = {
'bifrost-base': {
'type': 'url',
'location': ('$tarballs_base/bifrost/'
'bifrost-7.2.1.tar.gz')},
'bifrost-7.2.2.tar.gz')},
'blazar-base': {
'type': 'url',
'location': ('$tarballs_base/blazar/'


Loading…
Cancel
Save