Browse Source

Fix lower-constraints test fail due to failing dep build

Ubuntu Bionic updated OpenSSL package to new release:
from 1.1.0 to 1.1.1
It caused cryptography in version from lower-constraints
to fail to build in Zuul.
Additionally, constrained cryptography version did not
match the requirement for constrained PyOpenSSL.
This commit bumps the version to the minimum required
by constrained PyOpenSSL.
It works because manylinux1 (binary) wheel exists.
This version agrees also with upper-constraints for Queens.

Dependency on cryptography is removed as it is not used directly
by kolla (and requirements checker requires lower-constraints
matching version - let's not create an illusion of usage).

Change-Id: I8ae19f212049cae5dfb4e8dd6ec6cd14a8c46e0e
Signed-off-by: Radosław Piliszek <radoslaw.piliszek@gmail.com>
changes/76/664676/2
Radosław Piliszek 2 years ago
parent
commit
39a2cf066c
  1. 2
      lower-constraints.txt
  2. 1
      requirements.txt

2
lower-constraints.txt

@ -10,7 +10,7 @@ chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1
coverage==4.0
cryptography==1.9
cryptography==2.1.4
ddt==1.0.1
debtcollector==1.19.0
decorator==4.2.1

1
requirements.txt

@ -3,7 +3,6 @@
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
docker>=2.4.2 # Apache-2.0
cryptography>=1.9 # BSD/Apache-2.0
Jinja2>=2.8 # BSD License (3 clause)
GitPython>=1.0.1 # BSD License (3 clause)
six>=1.10.0 # MIT

Loading…
Cancel
Save