Browse Source

Debian: use QEMU 5 from buster-backports

This will allow us to make sure of all updates.

'qemu-kvm' got dropped in Debian

Three changes from master are merged into one:
Change Id: If09a8188030baa284dd353b1c3f830d78c5091b7
Change Id: I4371daf7b28c8a057364d17e2e47f6e22665447c
Change Id: I2c82c6269b2c357b0815ea29bc6a7c322f84dac9

Change-Id: I1b3e879ec8752c63dc3f1ec3d8f62c3b43df55f3
changes/86/782386/1
Marcin Juszkiewicz 7 months ago
parent
commit
3de3fea92f
  1. 10
      docker/base/apt_preferences.debian
  2. 7
      docker/nova/nova-libvirt/Dockerfile.j2

10
docker/base/apt_preferences.debian

@ -42,8 +42,12 @@ Package: openvswitch*
Pin: release n=buster
Pin-Priority: 700
# daxio in nova-compute depends on those
# in Victoria+ we have them as QEMU 5 dependencies
Package: libpmem1 libndctl6 libdaxctl1 pmdk-tools libpmemblk1 libpmemlog1 libpmemobj1 libpmempool1
# we want newer QEMU
Package: qemu*
Pin: version 1:5.*
Pin-Priority: 700
# daxio and QEMU depends on those
Package: libpmem1 libndctl6 libdaxctl1 pmdk-tools libpmemblk1 libpmemlog1 libpmemobj1 libpmempool1 liburing1 libfdt1
Pin: release n=buster-backports
Pin-Priority: 700

7
docker/nova/nova-libvirt/Dockerfile.j2

@ -59,8 +59,13 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
{% elif base_arch == "x86_64" %}
{% set nova_libvirt_packages = nova_libvirt_packages + [
'ovmf',
'qemu-kvm'
] %}
# NOTE(hrw): Debian merged 'qemu-kvm' into 'qemu-system-ARCH' in 5.0-9
{% if base_distro == 'ubuntu' %}
{% set nova_libvirt_packages = nova_libvirt_packages + [
'qemu-kvm'
] %}
{% endif %}
{% endif %}
{% if base_arch in ['aarch64', 'x86_64'] %}

Loading…
Cancel
Save