Update ubuntu dockerfiles for formatting

Change-Id: If4be00b937e14ec93443dcb7249cf17099d57cbe
Closes-Bug: #1569417
changes/38/317238/13
Swapnil Kulkarni (coolsvap) 7 years ago
parent f93739fa4f
commit 435b21b90d
  1. 8
      dev/vagrant/bootstrap.sh
  2. 2
      doc/vagrant-dev-env.rst
  3. 2
      docker/aodh/aodh-api/Dockerfile.j2
  4. 2
      docker/aodh/aodh-base/Dockerfile.j2
  5. 2
      docker/aodh/aodh-evaluator/Dockerfile.j2
  6. 2
      docker/aodh/aodh-expirer/Dockerfile.j2
  7. 2
      docker/aodh/aodh-listener/Dockerfile.j2
  8. 2
      docker/aodh/aodh-notifier/Dockerfile.j2
  9. 2
      docker/base/Dockerfile.j2
  10. 2
      docker/ceilometer/ceilometer-api/Dockerfile.j2
  11. 2
      docker/ceilometer/ceilometer-base/Dockerfile.j2
  12. 2
      docker/ceilometer/ceilometer-central/Dockerfile.j2
  13. 2
      docker/ceilometer/ceilometer-collector/Dockerfile.j2
  14. 4
      docker/ceilometer/ceilometer-compute/Dockerfile.j2
  15. 2
      docker/ceilometer/ceilometer-notification/Dockerfile.j2
  16. 2
      docker/ceph/ceph-base/Dockerfile.j2
  17. 2
      docker/cinder/cinder-api/Dockerfile.j2
  18. 2
      docker/cinder/cinder-backup/Dockerfile.j2
  19. 4
      docker/cinder/cinder-base/Dockerfile.j2
  20. 2
      docker/cinder/cinder-rpcbind/Dockerfile.j2
  21. 2
      docker/cinder/cinder-scheduler/Dockerfile.j2
  22. 2
      docker/cinder/cinder-volume/Dockerfile.j2
  23. 2
      docker/cron/Dockerfile.j2
  24. 2
      docker/designate/designate-api/Dockerfile.j2
  25. 2
      docker/designate/designate-backend-bind9/Dockerfile.j2
  26. 2
      docker/designate/designate-base/Dockerfile.j2
  27. 2
      docker/designate/designate-central/Dockerfile.j2
  28. 2
      docker/designate/designate-mdns/Dockerfile.j2
  29. 2
      docker/designate/designate-poolmanager/Dockerfile.j2
  30. 2
      docker/designate/designate-sink/Dockerfile.j2
  31. 2
      docker/dind/Dockerfile.j2
  32. 2
      docker/elasticsearch/Dockerfile.j2
  33. 4
      docker/glance/glance-base/Dockerfile.j2
  34. 2
      docker/gnocchi/gnocchi-base/Dockerfile.j2
  35. 2
      docker/haproxy/Dockerfile.j2
  36. 2
      docker/heat/heat-api-cfn/Dockerfile.j2
  37. 2
      docker/heat/heat-api/Dockerfile.j2
  38. 2
      docker/heat/heat-base/Dockerfile.j2
  39. 2
      docker/heat/heat-engine/Dockerfile.j2
  40. 4
      docker/horizon/Dockerfile.j2
  41. 2
      docker/ironic/ironic-api/Dockerfile.j2
  42. 2
      docker/ironic/ironic-base/Dockerfile.j2
  43. 4
      docker/ironic/ironic-conductor/Dockerfile.j2
  44. 2
      docker/ironic/ironic-pxe/Dockerfile.j2
  45. 2
      docker/iscsid/Dockerfile.j2
  46. 2
      docker/keepalived/Dockerfile.j2
  47. 4
      docker/keystone/Dockerfile.j2
  48. 2
      docker/kibana/Dockerfile.j2
  49. 2
      docker/manila/manila-api/Dockerfile.j2
  50. 4
      docker/manila/manila-base/Dockerfile.j2
  51. 2
      docker/manila/manila-scheduler/Dockerfile.j2
  52. 2
      docker/mariadb/Dockerfile.j2
  53. 2
      docker/memcached/Dockerfile.j2
  54. 2
      docker/mongodb/Dockerfile.j2
  55. 2
      docker/murano/murano-api/Dockerfile.j2
  56. 2
      docker/murano/murano-base/Dockerfile.j2
  57. 2
      docker/murano/murano-engine/Dockerfile.j2
  58. 4
      docker/neutron/neutron-base/Dockerfile.j2
  59. 2
      docker/neutron/neutron-dhcp-agent/Dockerfile.j2
  60. 2
      docker/neutron/neutron-l3-agent/Dockerfile.j2
  61. 4
      docker/neutron/neutron-linuxbridge-agent/Dockerfile.j2
  62. 2
      docker/neutron/neutron-metadata-agent/Dockerfile.j2
  63. 2
      docker/neutron/neutron-openvswitch-agent/Dockerfile.j2
  64. 2
      docker/nova/nova-api/Dockerfile.j2
  65. 4
      docker/nova/nova-base/Dockerfile.j2
  66. 2
      docker/nova/nova-compute-ironic/Dockerfile.j2
  67. 4
      docker/nova/nova-compute/Dockerfile.j2
  68. 2
      docker/nova/nova-conductor/Dockerfile.j2
  69. 2
      docker/nova/nova-consoleauth/Dockerfile.j2
  70. 2
      docker/nova/nova-libvirt/Dockerfile.j2
  71. 2
      docker/nova/nova-network/Dockerfile.j2
  72. 2
      docker/nova/nova-novncproxy/Dockerfile.j2
  73. 2
      docker/nova/nova-scheduler/Dockerfile.j2
  74. 2
      docker/nova/nova-spicehtml5proxy/Dockerfile.j2
  75. 2
      docker/nova/nova-ssh/Dockerfile.j2
  76. 4
      docker/openstack-base/Dockerfile.j2
  77. 2
      docker/openvswitch/openvswitch-base/Dockerfile.j2
  78. 2
      docker/rabbitmq/Dockerfile.j2
  79. 2
      docker/swift/swift-account/Dockerfile.j2
  80. 4
      docker/swift/swift-base/Dockerfile.j2
  81. 2
      docker/swift/swift-container/Dockerfile.j2
  82. 2
      docker/swift/swift-object/Dockerfile.j2
  83. 2
      docker/swift/swift-proxy-server/Dockerfile.j2
  84. 2
      docker/swift/swift-rsyncd/Dockerfile.j2
  85. 2
      docker/tempest/Dockerfile.j2
  86. 2
      docker/tgtd/Dockerfile.j2
  87. 2
      docker/trove/trove-api/Dockerfile.j2
  88. 2
      docker/trove/trove-base/Dockerfile.j2
  89. 2
      docker/trove/trove-conductor/Dockerfile.j2
  90. 2
      docker/trove/trove-guestagent/Dockerfile.j2
  91. 2
      docker/trove/trove-taskmanager/Dockerfile.j2
  92. 2
      tools/setup_Debian.sh

@ -31,7 +31,7 @@ function _ensure_lsb_release {
fi
if [[ -x $(which apt-get 2>/dev/null) ]]; then
apt-get install -y lsb-release
apt-get -y install lsb-release
elif [[ -x $(which yum 2>/dev/null) ]]; then
yum -y install redhat-lsb-core
fi
@ -71,7 +71,7 @@ function prep_work {
yum -y install MySQL-python vim-enhanced python-pip python-devel gcc openssl-devel libffi-devel libxml2-devel libxslt-devel
elif is_ubuntu; then
apt-get update
apt-get install -y python-mysqldb python-pip python-dev build-essential libssl-dev libffi-dev libxml2-dev libxslt-dev
apt-get -y install python-mysqldb python-pip python-dev build-essential libssl-dev libffi-dev libxml2-dev libxslt-dev
else
echo "Unsupported Distro: $DISTRO" 1>&2
exit 1
@ -118,7 +118,7 @@ EOF
apt-key adv --keyserver hkp://pgp.mit.edu:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
echo "deb https://apt.dockerproject.org/repo ubuntu-wily main" > /etc/apt/sources.list.d/docker.list
apt-get update
apt-get install -y docker-engine
apt-get -y install docker-engine
sed -i -r "s,(ExecStart)=(.+),\1=/usr/bin/docker daemon --insecure-registry ${REGISTRY} --registry-mirror=http://${REGISTRY}|" /lib/systemd/system/docker.service
else
echo "Unsupported Distro: $DISTRO" 1>&2
@ -161,7 +161,7 @@ function configure_operator {
if is_centos; then
yum -y install git mariadb
elif is_ubuntu; then
apt-get install -y git mariadb-client selinux-utils
apt-get -y install git mariadb-client selinux-utils
else
echo "Unsupported Distro: $DISTRO" 1>&2
exit 1

@ -45,7 +45,7 @@ On Fedora 22 it is as easy as::
On Ubuntu 14.04 it is as easy as::
sudo apt-get install vagrant ruby-dev ruby-libvirt python-libvirt libvirt-dev nfs-kernel-server
sudo apt-get -y install vagrant ruby-dev ruby-libvirt python-libvirt libvirt-dev nfs-kernel-server
**Note:** Many distros ship outdated versions of Vagrant by default. When in
doubt, always install the latest from the downloads page above.

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-api \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-common \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-evaluator \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-expirer \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-listener \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
aodh-notifier \
&& apt-get clean

@ -197,7 +197,7 @@ RUN apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 199369E540
&& apt-get update \
&& apt-get upgrade -y \
&& apt-get dist-upgrade -y \
&& apt-get install -y --no-install-recommends \
&& apt-get -y install --no-install-recommends \
ca-certificates \
python \
curl \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-api \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-common \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-agent-central \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-collector \
&& apt-get clean

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-agent-compute \
python-ceilometerclient \
&& apt-get clean
@ -26,7 +26,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
libvirt-dev \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceilometer-agent-notification \
&& apt-get clean

@ -13,7 +13,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceph \
radosgw \
parted \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
cinder-api \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
cinder-backup \
&& apt-get clean

@ -14,7 +14,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
cinder-common \
ceph-common \
lvm2 \
@ -33,7 +33,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
lvm2 \
qemu-utils \
ceph-common \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
rpcbind \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
cinder-scheduler \
&& apt-get clean

@ -11,7 +11,7 @@ RUN sed -i '1 i include /var/lib/cinder/volumes/*' /etc/tgt/tgtd.conf
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
tgt \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
cron \
logrotate \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
designate-api \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
bind9 \
&& apt-get clean

@ -19,7 +19,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
designate-common \
python-tooz \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu']%}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
designate-central \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
designate-mdns \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
bind9 \
designate-pool-manager \
&& apt-get clean

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
designate-sink \
designateclient \
&& apt-get clean

@ -13,7 +13,7 @@ RUN /bin/true
RUN echo 'deb http://apt.dockerproject.org/repo ubuntu-trusty main' > /etc/apt/sources.list.d/docker.list \
&& apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D \
&& apt-get update \
&& apt-get install -y --no-install-recommends \
&& apt-get -y install --no-install-recommends \
btrfs-tools \
docker-engine=1.8.2-0~trusty \
openssh-server \

@ -14,7 +14,7 @@ RUN yum -y install \
ENV JAVA_HOME /usr/lib/jvm/java-1.7.0-openjdk-amd64/
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openjdk-7-jre \
elasticsearch \
&& apt-get clean

@ -13,7 +13,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
glance \
python-rbd \
python-rados \
@ -32,7 +32,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
python-rbd \
python-rados \
&& apt-get clean \

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif install_type == 'source' %}
{% if base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends libpq-dev \
RUN apt-get -y install --no-install-recommends libpq-dev \
&& apt-get clean
{% endif %}

@ -9,7 +9,7 @@ RUN yum -y install \
{% elif base_distro in ['debian', 'ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
haproxy \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
heat-api-cfn \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
heat-api \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
heat-common \
&& apt-get clean

@ -14,7 +14,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
heat-engine \
&& apt-get clean

@ -22,7 +22,7 @@ RUN sed -i "s|WEBROOT = '/dashboard/'|WEBROOT = '/'|" /etc/openstack-dashboard/l
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openstack-dashboard \
apache2 \
libapache2-mod-wsgi \
@ -54,7 +54,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
apache2 \
libapache2-mod-wsgi \
&& echo > /etc/apache2/ports.conf \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ironic-api \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ironic-common \
&& apt-get clean

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ironic-conductor \
qemu-utils \
ipmitool \
@ -28,7 +28,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
qemu-utils \
ipmitool \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
tftpd-hpa \
syslinux-common \
syslinux \

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
open-iscsi \
targetcli \
python-rtslib \

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
keepalived \
socat \
&& apt-get clean

@ -17,7 +17,7 @@ RUN mkdir -p /var/www/cgi-bin/keystone \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
keystone \
apache2 \
libapache2-mod-wsgi \
@ -40,7 +40,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
apache2 \
libapache2-mod-wsgi \
&& echo > /etc/apache2/ports.conf \

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
kibana \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
manila-api \
&& apt-get clean

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
manila-common \
openvswitch-switch \
&& apt-get clean
@ -26,7 +26,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openvswitch-switch \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
manila-scheduler \
&& apt-get clean

@ -19,7 +19,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
mariadb-galera-server \
percona-xtrabackup \
socat \

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
{% set user = 'memcache' %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
memcached \
&& apt-get clean \
&& usermod -a -G kolla {{ user }}

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
mongodb-server \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
murano-api \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
murano-common \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if install_type == 'binary' %}
{% if base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
murano-engine \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
neutron-plugin-ml2 \
neutron-server \
openvswitch-switch \
@ -35,7 +35,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
arping \
conntrack \
dnsmasq \

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if base_distro in ['ubuntu', 'debian'] %}
{% if install_type == 'binary' %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
neutron-dhcp-agent \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if base_distro in ['ubuntu', 'debian'] %}
{% if install_type == 'binary' %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
neutron-l3-agent \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ebtables \
neutron-plugin-linuxbridge-agent \
&& apt-get clean
@ -28,7 +28,7 @@ RUN yum -y install \
&& yum clean all
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y \
RUN apt-get -y install \
ebtables \
bridge-utils \
&& apt-get clean

@ -4,7 +4,7 @@ MAINTAINER {{ maintainer }}
{% if base_distro in ['ubuntu', 'debian'] %}
{% if install_type == 'binary' %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
neutron-metadata-agent \
&& apt-get clean

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openvswitch-switch \
neutron-plugin-openvswitch-agent \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-api \
python-memcache \
&& apt-get clean

@ -14,7 +14,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-common \
python-nova \
bridge-utils \
@ -32,7 +32,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
iptables \
ebtables \
dnsmasq \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-compute \
&& apt-get clean

@ -18,7 +18,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
# ironic as workaround https://bugs.launchpad.net/packstack/+bug/1430388
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-compute \
openvswitch-switch \
sysfsutils \
@ -50,7 +50,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
libvirt-dev \
qemu-utils \
ceph-common \

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-conductor \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-consoleauth \
python-memcache \
&& apt-get clean

@ -17,7 +17,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ceph-common \
libvirt-bin \
dmidecode \

@ -12,7 +12,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-network \
&& apt-get clean

@ -11,7 +11,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-novncproxy \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-scheduler \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
nova-spiceproxy \
&& apt-get clean

@ -9,7 +9,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openssh-server \
&& apt-get clean \
&& mkdir -p /var/run/sshd \

@ -158,7 +158,7 @@ RUN yum -y install \
# This will prevent questions from being asked during the install
ENV DEBIAN_FRONTEND noninteractive
# There is no python-tuskarclient in ubuntu 14.04
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
python-barbicanclient \
python-ceilometerclient \
python-congressclient \
@ -204,7 +204,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
ca-certificates \
build-essential \
python-dev \

@ -9,7 +9,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
openvswitch-switch \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
rabbitmq-server \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
swift-account \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
swift \
&& apt-get clean
@ -24,7 +24,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
liberasurecode-dev \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
swift-container \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
swift-object \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
swift-proxy \
&& apt-get clean

@ -9,7 +9,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
rsync \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
tempest \
&& apt-get clean

@ -11,7 +11,7 @@ RUN sed -i '1 i include /var/lib/cinder/volumes/*' /etc/tgt/tgtd.conf
{% elif base_distro in ['ubuntu', 'debian'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
tgt \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
trove-api \
&& apt-get clean

@ -10,7 +10,7 @@ RUN yum -y install \
{% elif base_distro in ['ubuntu'] %}
RUN apt-get install -y --no-install-recommends \
RUN apt-get -y install --no-install-recommends \
trove-common \
&& apt-get clean