Browse Source

nova-libvirt: add UEFI packages to support UEFI instances

Fix inability to run UEFI-based images/instances by installing UEFI
packages also in nova-libvirt image which is not based on nova-base.

Adapted for Stein and below (e.g. Rocky) by removing
any C8 support.

Closes-Bug: #1814552
Co-authored-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Co-authored-by: Radosław Piliszek <radoslaw.piliszek@gmail.com>
Change-Id: I1d5cd3d9af98444acac5bedd7daeaa6c6673dcd6
(cherry picked from commit 15b68c15c1)
(cherry picked from commit ffaf585d0f)
changes/61/706061/2
chenxing Radosław Piliszek 6 months ago
parent
commit
757fe57563
2 changed files with 24 additions and 0 deletions
  1. +18
    -0
      docker/nova/nova-libvirt/Dockerfile.j2
  2. +6
    -0
      releasenotes/notes/bug-1814552-a037354969dcf7e5.yaml

+ 18
- 0
docker/nova/nova-libvirt/Dockerfile.j2 View File

@@ -31,6 +31,16 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
] %}
{% endif %}

{% if base_arch == 'x86_64' %}
{% set nova_libvirt_packages = nova_libvirt_packages + [
'OVMF'
] %}
{% elif base_arch == 'aarch64' %}
{% set nova_libvirt_packages = nova_libvirt_packages + [
'AAVMF'
] %}
{% endif %}

{% elif base_package_type == 'deb' %}

{% set nova_libvirt_packages = [
@@ -54,6 +64,7 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
] %}
{% elif base_arch == "x86_64" %}
{% set nova_libvirt_packages = nova_libvirt_packages + [
'ovmf',
'qemu-kvm'
] %}
{% endif %}
@@ -78,6 +89,13 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build

RUN rm -f /etc/libvirt/qemu/networks/default.xml /etc/libvirt/qemu/networks/autostart/default.xml

{% elif base_package_type == 'rpm' %}

{% if base_arch == 'x86_64' %}
# NOTE(jeffrey4l): for x86_64, nova will validate the existence of /usr/share/OVMF/OVMF_CODE.fd
RUN ln -sf /usr/share/OVMF/OVMF_CODE.secboot.fd /usr/share/OVMF/OVMF_CODE.fd
{% endif %}

{% endif %}

COPY extend_start.sh /usr/local/bin/kolla_extend_start


+ 6
- 0
releasenotes/notes/bug-1814552-a037354969dcf7e5.yaml View File

@@ -0,0 +1,6 @@
---
fixes:
- |
Fix inability to run UEFI-based images/instances by installing UEFI packages
also in nova-libvirt image which is not based on nova-base.
`LP#1814552 <https://launchpad.net/bugs/1814552>`

Loading…
Cancel
Save