Browse Source

Fix lower-constraints test fail due to failing dep build

Ubuntu Bionic updated OpenSSL package to new release:
from 1.1.0 to 1.1.1
It caused cryptography in version from lower-constraints
to fail to build in Zuul.
Additionally, constrained cryptography version did not
match the requirement for constrained PyOpenSSL.
This commit bumps the version to the minimum required
by constrained PyOpenSSL.
It works because manylinux1 (binary) wheel exists.
This version agrees also with upper-constraints for Queens.

Dependency on cryptography is removed as it is not used directly
by kolla (and requirements checker requires lower-constraints
matching version - let's not create an illusion of usage).

For stable/stein additionally fix version of sphinx to pass CI.

Change-Id: I8ae19f212049cae5dfb4e8dd6ec6cd14a8c46e0e
Signed-off-by: Radosław Piliszek <radoslaw.piliszek@gmail.com>
(cherry picked from commit 39a2cf066c)
changes/88/665188/3
Radosław Piliszek 2 years ago
parent
commit
7a23046b28
3 changed files with 3 additions and 3 deletions
  1. +2
    -1
      doc/requirements.txt
  2. +1
    -1
      lower-constraints.txt
  3. +0
    -1
      requirements.txt

+ 2
- 1
doc/requirements.txt View File

@ -4,4 +4,5 @@
doc8>=0.6.0 # Apache-2.0
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD

+ 1
- 1
lower-constraints.txt View File

@ -10,7 +10,7 @@ chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1
coverage==4.0
cryptography==1.9
cryptography==2.1.4
ddt==1.0.1
debtcollector==1.19.0
decorator==4.2.1


+ 0
- 1
requirements.txt View File

@ -3,7 +3,6 @@
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
docker>=2.4.2 # Apache-2.0
cryptography>=1.9 # BSD/Apache-2.0
Jinja2>=2.8 # BSD License (3 clause)
GitPython>=1.0.1 # BSD License (3 clause)
six>=1.10.0 # MIT


Loading…
Cancel
Save