Browse Source

Sensu: Remove ceph and process-checks plugins from client

The sensu image became unbuildable, failing to install the ceph plugin:

    Unable to resolve dependencies: sensu-plugins-ceph requires english (= 0.6.3)

This has happened because the author of the 'english' gem has seen fit
to publish a new 0.7.0 release, and 'yank' [1] all previous releases
from rubygems.

This change removes the ceph and process-checks plugins, which both
suffer from a dependency on the yanked english 0.6.3.

[1] https://rubygems.org/gems/english/versions/0.6.3

Change-Id: I9d34413fa10b5a2920aca60b08141bfaddcc7415
Closes-Bug: #1871600
(cherry picked from commit 818dc4d6ff)
changes/76/718476/1
Mark Goddard 1 year ago
committed by Radosław Piliszek
parent
commit
80caffa8c8
  1. 2
      docker/sensu/sensu-client/Dockerfile.j2

2
docker/sensu/sensu-client/Dockerfile.j2

@ -61,7 +61,6 @@ RUN echo '{{ image_name }} not yet available for {{ base_distro }}' \
# Let's cap them to the known major version that works with the ruby shipped on
# rhel/centos/oraclelinux (currently 2.0)
{% set sensu_plugins = [
'ceph:"~>1"',
'cpu-checks:"~>1"',
'disk-checks:"~>2"',
'dns:"~>1"',
@ -79,7 +78,6 @@ RUN echo '{{ image_name }} not yet available for {{ base_distro }}' \
'network-checks:"~>2"',
'ntp:"~>1"',
'openstack:"~>1"',
'process-checks:"~>2"',
'rabbitmq:"~>3"',
'redis:"~>2"',
'uptime-checks:"~>1"',

Loading…
Cancel
Save