Browse Source

Add pciutils package to cyborg-agent and zun-compute

These run lspci and have this requirement in respective bindeps.

CentOS images seem to have it installed but Ubuntu not.
Ensure pciutils package is always installed.

zun-compute seemed to work nonetheless but generated errors
about being unable to take host inventory.

cyborg-agent is unknown to work at all and deb is unbuildable.

Change-Id: Iebc1f2c05c1f57c2b6f98ca9772f1ae9d9a420fa
Signed-off-by: Radosław Piliszek <radoslaw.piliszek@gmail.com>
(cherry picked from commit c323c5be7f)
tags/8.0.1
Radosław Piliszek 1 month ago
parent
commit
904f1fcbd7
2 changed files with 14 additions and 0 deletions
  1. 6
    0
      docker/cyborg/cyborg-agent/Dockerfile.j2
  2. 8
    0
      docker/zun/zun-compute/Dockerfile.j2

+ 6
- 0
docker/cyborg/cyborg-agent/Dockerfile.j2 View File

@@ -4,6 +4,10 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
4 4
 {% block cyborg_agent_header %}{% endblock %}
5 5
 {% import "macros.j2" as macros with context %}
6 6
 
7
+{% set cyborg_agent_packages = [
8
+    'pciutils',
9
+] %}
10
+
7 11
 {% if install_type == 'binary' %}
8 12
 
9 13
 RUN echo '{{ install_type }} not yet available for {{ base_distro }}'  \
@@ -17,6 +21,8 @@ RUN echo '{{ install_type }} not yet available for {{ base_distro }}'  \
17 21
 
18 22
 {% endif %}
19 23
 
24
+{{ macros.install_packages(cyborg_agent_packages | customizable("packages")) }}
25
+
20 26
 RUN {{ macros.install_pip(cyborg_agent_pip_packages | customizable("pip_packages")) }} 
21 27
 
22 28
 {% if base_package_type == 'rpm' %}

+ 8
- 0
docker/zun/zun-compute/Dockerfile.j2 View File

@@ -3,6 +3,8 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
3 3
 
4 4
 {% block zun_compute_header %}{% endblock %}
5 5
 
6
+{% import "macros.j2" as macros with context %}
7
+
6 8
 {% if install_type == 'binary' %}
7 9
 
8 10
 RUN echo '{{ install_type }} not yet available for {{ base_distro }}' \
@@ -10,6 +12,12 @@ RUN echo '{{ install_type }} not yet available for {{ base_distro }}' \
10 12
 
11 13
 {% endif %}
12 14
 
15
+{% set zun_compute_packages = [
16
+    'pciutils',
17
+] %}
18
+
19
+{{ macros.install_packages(zun_compute_packages | customizable("packages")) }}
20
+
13 21
 COPY zun_sudoers /etc/sudoers.d/kolla_zun_sudoers
14 22
 COPY extend_start.sh /usr/local/bin/kolla_zun_extend_start
15 23
 

Loading…
Cancel
Save