[ussuri][goal] More cleanup for python 2.7 drop

Cleanup requirement and set ignore_basepython_conflict = True
in tox to avoid python version conflict warning which going
to be error in future.

Change-Id: Ia749d558df33f475dfdbe7a1f9dfdb30aeba8da0
changes/91/710591/1
Ghanshyam Mann 3 years ago
parent 74d5a66e6b
commit b9417cd745

@ -5,5 +5,5 @@
doc8>=0.6.0 # Apache-2.0
openstackdocstheme>=1.19.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD

@ -4,7 +4,7 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
docker>=2.4.2 # Apache-2.0
Jinja2>=2.8 # BSD License (3 clause)
GitPython>=1.0.1;python_version>='3.0' # BSD License (3 clause)
GitPython>=1.0.1 # BSD License (3 clause)
oslo.config>=5.1.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,!=36.2.0,>=21.0 # PSF/ZPL

@ -1,7 +1,8 @@
[tox]
minversion = 2.5.0
minversion = 3.1
skipsdist = True
envlist = pep8,py37,pypy
ignore_basepython_conflict = True
[testenv]
basepython = python3

Loading…
Cancel
Save