Browse Source

Use upper constraints for virtualenv in openstack-base

Since Rally has virtualenv in requirements, and is using contraints - it's
trying to downgrade virtualenv from inside a virtualenv.
Let's try to install proper version of packages in openstack-base.

Closes-Bug: #1900419
Change-Id: I2a1e2b6661fd4b62648756416e6147b604dda686
(cherry picked from commit b1709a87ed)
changes/66/760566/1
Michal Nasiadka 2 years ago committed by Bartosz Bezak
parent
commit
bebad0409e
  1. 2
      docker/openstack-base/Dockerfile.j2

2
docker/openstack-base/Dockerfile.j2

@ -313,7 +313,7 @@ ENV DEBIAN_FRONTEND noninteractive
ADD openstack-base-archive /openstack-base-source
RUN ln -s openstack-base-source/* /requirements \
&& mkdir -p /var/lib/kolla \
&& {{ macros.install_pip(['virtualenv'], constraints = false)}} \
&& {{ macros.install_pip(['virtualenv'])}} \
&& virtualenv --system-site-packages /var/lib/kolla/venv
ENV PATH /var/lib/kolla/venv/bin:$PATH

Loading…
Cancel
Save