Browse Source

Pin rabbitmq-server to 3.7.10

New version of rabbitmq-server in epel but not new enough version of
erlang available in epel or delorean-trunk repos.

Closes-Bug: #1814233
Change-Id: Iac3cad17ff8279a2be66ffe1366d6844f999d66f
tags/8.0.0.0rc1
Jon Schlueter 6 months ago
parent
commit
cfbcf830f0
1 changed files with 3 additions and 1 deletions
  1. 3
    1
      docker/rabbitmq/Dockerfile.j2

+ 3
- 1
docker/rabbitmq/Dockerfile.j2 View File

@@ -9,10 +9,12 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
9 9
 
10 10
 {% block rabbitmq_install %}
11 11
 {% if base_package_type == 'rpm' %}
12
+# NOTE(mandre) Remove rabbitmq-server pinning once package dependencies are met
13
+# https://bugs.launchpad.net/kolla/+bug/1814233
12 14
     {% set rabbitmq_packages = [
13 15
         'erlang-hipe',
14 16
         'hostname',
15
-        'rabbitmq-server'
17
+        'rabbitmq-server-3.7.10'
16 18
     ] %}
17 19
 
18 20
 {% elif base_package_type == 'deb' %}

Loading…
Cancel
Save