Browse Source

Fixes swift-object-expirer for Debian and Ubuntu binary images.

Replaces 'swift-object' package with 'swift-object-expirer' package.

Change-Id: I8fa3fcad88b35743e042d8a62ccee722b08af673
Closes-Bug: #1859607
(cherry picked from commit 190a6f7a26)
changes/93/703493/1
Dincer Celik 2 years ago
parent
commit
d9c63d7b81
  1. 2
      docker/swift/swift-object-expirer/Dockerfile.j2
  2. 5
      releasenotes/notes/swift-object-expirer-fix-b837de80cea4fb8e.yaml

2
docker/swift/swift-object-expirer/Dockerfile.j2

@ -10,7 +10,7 @@ LABEL maintainer="{{ maintainer }}" name="{{ image_name }}" build-date="{{ build
# RDO packages swift-object-expirer in openstack-swift-proxy
{% set swift_object_expirer_packages = ['openstack-swift-proxy'] %}
{% elif base_package_type == 'deb' %}
{% set swift_object_expirer_packages = ['swift-object'] %}
{% set swift_object_expirer_packages = ['swift-object-expirer'] %}
{% endif %}
{{ macros.install_packages(swift_object_expirer_packages | customizable("packages")) }}

5
releasenotes/notes/swift-object-expirer-fix-b837de80cea4fb8e.yaml

@ -0,0 +1,5 @@
---
fixes:
- |
Fixes swift-object-expirer for Debian and Ubuntu binary images.
`LP#1859607 <https://bugs.launchpad.net/kolla/+bug/1859607>`__
Loading…
Cancel
Save