Browse Source

Fix masakari-monitors image on CentOS 8

Train only.

The version of libvirt-python allowed by upper-constraints in Train
(5.7.0) does not support CentOS 8. This prevented the masakari-monitors
image from building.

This change modifies the upper constraints file in the masakari-monitors
image to use 5.10.0, the earliest version that does support CentOS 8.

Change-Id: Ia980be14fdf9c4fc15bb379b940ae491de035725
changes/78/743178/1
Mark Goddard 2 months ago
parent
commit
e3e2da2e92
3 changed files with 5 additions and 1 deletions
  1. +1
    -0
      docker/masakari/masakari-monitors/Dockerfile.j2
  2. +0
    -1
      kolla/image/build.py
  3. +4
    -0
      releasenotes/notes/fix-masakari-monitors-centos8-6b030ab9531505be.yaml

+ 1
- 0
docker/masakari/masakari-monitors/Dockerfile.j2 View File

@@ -41,6 +41,7 @@ ADD masakari-monitors-archive /masakari-monitors-source
] %}

RUN ln -s masakari-monitors-source/* masakari-monitors \
{% if distro_package_manager == 'dnf' %}&& sed -i -e 's/libvirt-python===.*/libvirt-python===5.10.0/' /requirements/upper-constraints.txt {% endif %}\
&& {{ macros.install_pip(masakari_monitors_pip_packages | customizable("pip_packages")) }} \
&& mkdir -p /etc/masakari-monitors \
&& chown -R masakari: /etc/masakari-monitors


+ 0
- 1
kolla/image/build.py View File

@@ -167,7 +167,6 @@ UNBUILDABLE_IMAGES = {

'centos8+source': {
"cyborg-agent", # opae-sdk does not support CentOS 8
"masakari-monitors", # python-libvirt===5.7.0 fails
},

'debian': {


+ 4
- 0
releasenotes/notes/fix-masakari-monitors-centos8-6b030ab9531505be.yaml View File

@@ -0,0 +1,4 @@
---
fixes:
- |
Fixes the ``masakari-monitors`` image on CentOS 8.

Loading…
Cancel
Save