Browse Source

Fix installation with Vagrant

Current DevStack version does not support Ubuntu Xenial,
we should update the Vagrantfile to use Bionic instead.
Also, current DevStack requires IPv6 to be enabled on
the VM, let's make sure that is present.

Change-Id: I6fad390367476ed50cac38d84edee4387c2275f1
changes/02/757602/2
Maysa Macedo 6 months ago
parent
commit
8799fa9685
2 changed files with 7 additions and 3 deletions
  1. +3
    -3
      contrib/vagrant/Vagrantfile
  2. +4
    -0
      contrib/vagrant/vagrant.sh

+ 3
- 3
contrib/vagrant/Vagrantfile View File

@ -9,21 +9,21 @@ Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
config.vm.hostname = 'devstack'
config.vm.provider 'virtualbox' do |v, override|
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'bento/ubuntu-16.04')
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'generic/ubuntu1804')
v.memory = VM_MEMORY
v.cpus = VM_CPUS
v.customize "post-boot", ['controlvm', :id, 'setlinkstate1', 'on']
end
config.vm.provider 'parallels' do |v, override|
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'bento/ubuntu-16.04')
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'generic/ubuntu1804')
v.memory = VM_MEMORY
v.cpus = VM_CPUS
v.customize ['set', :id, '--nested-virt', 'on']
end
config.vm.provider 'libvirt' do |v, override|
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'yk0/ubuntu-xenial')
override.vm.box = ENV.fetch('VAGRANT_KURYR_VM_BOX', 'generic/ubuntu1804')
v.memory = VM_MEMORY
v.cpus = VM_CPUS
v.nested = true


+ 4
- 0
contrib/vagrant/vagrant.sh View File

@ -17,5 +17,9 @@ export HOST_IP=127.0.0.1
# run script
bash /vagrant/devstack.sh "$1"
# Enable IPv6
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=0
sudo sysctl -w net.ipv6.conf.all.disable_ipv6=0
#set environment variables for kuryr
su "$OS_USER" -c "echo 'source /vagrant/config/kuryr_rc' >> ~/.bash_profile"

Loading…
Cancel
Save