Browse Source

Merge "For OpenSUSE Leap, use more recent version of zVMCloudConnector"

Zuul 1 month ago
parent
commit
c47dc363ef
1 changed files with 9 additions and 0 deletions
  1. 9
    0
      scripts/requirements.sh

+ 9
- 0
scripts/requirements.sh View File

@@ -20,6 +20,15 @@ fi
20 20
 # anymore
21 21
 sed -i '/python-qpid-proton===0.14.0/d' /upper-constraints.txt
22 22
 
23
+# zVMCloudConnector for queens requires python<=3.5, but Leap has already python3.6
24
+case ${distro} in
25
+    opensuse|opensuse-leap|opensuse-tumbleweed|sles)
26
+        if [[ "${PYTHON3}" != "no" ]] && [[ "${PROJECT_REF}" == "stable/queens" ]]; then
27
+            sed -i 's/zVMCloudConnector===0.3.5/zVMCloudConnector===1.0.0/' /upper-constraints.txt
28
+        fi
29
+    ;;
30
+esac
31
+
23 32
 if [[ "${PYTHON3}" == "no" ]]; then
24 33
     ignore_wheels=py2
25 34
 else

Loading…
Cancel
Save