Browse Source

Upgrade pause image to version 3.1

k8s.gcr.io/pause image repository support mutilarch on version 3.1.
Pulling other non-amd64 arch image, no need to go to other arch specific
repository ,like pause-arm64. It is easy to support mutilarch, like
amd64, arm64, ppc64le, if use version 3.1.
See 3.1 manifest:
https://console.cloud.google.com/gcr/images/google-containers/GLOBAL/pause@sha256:f78411e19d84a252e53bff71a4407a5686c46983a2c2eeed83929b888179acea/details?tab=info

Change-Id: Id4a5dfc3bc3c9ce909c7b0a3709506a250b2851f
Task: 37841
Story: 2007026
changes/69/707069/1
Xinliang Liu 1 week ago
parent
commit
0b5d029179
3 changed files with 3 additions and 3 deletions
  1. +1
    -1
      doc/source/user/index.rst
  2. +1
    -1
      magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-master.sh
  3. +1
    -1
      magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-minion.sh

+ 1
- 1
doc/source/user/index.rst View File

@@ -1179,7 +1179,7 @@ _`container_infra_prefix`
* docker.io/openstackmagnum/kubernetes-proxy
* docker.io/openstackmagnum/kubernetes-scheduler
* docker.io/k8scloudprovider/k8s-keystone-auth
* gcr.io/google_containers/pause:3.0
* gcr.io/google_containers/pause:3.1

Images that might be needed:


+ 1
- 1
magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-master.sh View File

@@ -403,7 +403,7 @@ sed -i '/^KUBE_SCHEDULER_ARGS=/ s/=.*/="--leader-elect=true"/' /etc/kubernetes/s

$ssh_cmd mkdir -p /etc/kubernetes/manifests
KUBELET_ARGS="--register-node=true --pod-manifest-path=/etc/kubernetes/manifests --hostname-override=${INSTANCE_NAME}"
KUBELET_ARGS="${KUBELET_ARGS} --pod-infra-container-image=${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}pause:3.0"
KUBELET_ARGS="${KUBELET_ARGS} --pod-infra-container-image=${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}pause:3.1"
KUBELET_ARGS="${KUBELET_ARGS} --cluster_dns=${DNS_SERVICE_IP} --cluster_domain=${DNS_CLUSTER_DOMAIN}"
KUBELET_ARGS="${KUBELET_ARGS} --volume-plugin-dir=/var/lib/kubelet/volumeplugins"
KUBELET_ARGS="${KUBELET_ARGS} ${KUBELET_OPTIONS}"

+ 1
- 1
magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-minion.sh View File

@@ -256,7 +256,7 @@ fi
# For using default log-driver, other options should be ignored
sed -i 's/\-\-log\-driver\=journald//g' /etc/sysconfig/docker

KUBELET_ARGS="${KUBELET_ARGS} --pod-infra-container-image=${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}pause:3.0"
KUBELET_ARGS="${KUBELET_ARGS} --pod-infra-container-image=${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}pause:3.1"
if [ -n "${INSECURE_REGISTRY_URL}" ]; then
echo "INSECURE_REGISTRY='--insecure-registry ${INSECURE_REGISTRY_URL}'" >> /etc/sysconfig/docker
fi

Loading…
Cancel
Save