Sync from oslo requirements

it is needed to synch from requirements for future integration
with openstack requirements easily in kilo or later

refer: https://github.com/openstack/requirements

Change-Id: I752cf7ad8dcc4c576b67f63ee2da5e56da6f6fee
changes/29/147029/2
Kennan 8 years ago
parent bbb4c7f0b5
commit 2fd10c5fca

@ -5,13 +5,13 @@
pbr>=0.6,!=0.7,<1.0
Babel>=1.3
oslo.concurrency>=0.1.0
oslo.config>=1.4.0
oslo.concurrency>=0.3.0 # Apache-2.0
oslo.config>=1.6.0
oslo.context>=0.1.0 # Apache-2.0
oslo.db>=0.2.0 # Apache-2.0
oslo.messaging>=1.4.0
oslo.serialization>=1.0.0
oslo.utils>=1.0.0
oslo.db>=1.3.0 # Apache-2.0
oslo.messaging>=1.4.0,!=1.5.0
oslo.serialization>=1.2.0 # Apache-2.0
oslo.utils>=1.2.0 # Apache-2.0
paramiko>=1.13.0
pecan>=0.8.0
keystonemiddleware>=1.0.0
@ -19,7 +19,7 @@ python-heatclient>=0.2.9
python-keystoneclient>=0.11.1
python-zaqarclient>=0.0.3
six>=1.7.0
SQLAlchemy>=0.8.4,!=0.9.5,<=0.9.99
SQLAlchemy>=0.9.7,<=0.9.99
WSME>=0.6
docker-py>=0.5.1
jsonpatch>=1.1

@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr'],
pbr=True)

@ -15,4 +15,4 @@ oslosphinx>=2.2.0
oslotest>=1.2.0
testrepository>=0.0.18
testscenarios>=0.4
testtools>=0.9.36,!=1.2.0,!=1.4.0
testtools>=0.9.36,!=1.2.0

Loading…
Cancel
Save