Browse Source

Fix incompatible requirement

- Fix lower-constraints don't match the lower bounds
in the requirements file(s). It may cause fail in
requirements-check.

Example fail: https://review.openstack.org/#/c/555209/

REF:
http://lists.openstack.org/pipermail/openstack-dev/2018-April/129056.html

- Fix incompatible of eventlet in requirement.txt

Change-Id: I85486f47e08bac6cfb481871861f37d692025f58
changes/69/560269/8
Nguyen Hai 3 years ago
parent
commit
338b045c23
  1. 114
      lower-constraints.txt
  2. 2
      requirements.txt

114
lower-constraints.txt

@ -1,33 +1,34 @@
alabaster==0.7.10
alembic==0.9.8
alembic==0.8.10
amqp==2.2.2
appdirs==1.4.3
asn1crypto==0.24.0
automaton==1.14.0
Babel==2.5.3
bandit==1.4.0
Babel==2.3.4
bandit==1.1.0
bashate==0.5.1
beautifulsoup4==4.6.0
cachetools==2.0.1
certifi==2018.1.18
cffi==1.11.5
chardet==3.0.4
cliff==2.11.0
cliff==2.8.0
cmd2==0.8.1
contextlib2==0.5.5
coverage==4.5.1
cryptography==2.1.4
coverage==4.0
cryptography==2.1
debtcollector==1.19.0
decorator==4.2.1
decorator==3.4.0
deprecation==2.0
doc8==0.8.0
docker==3.1.1
doc8==0.6.0
docker-pycreds==0.2.2
docker==2.4.2
docutils==0.14
dogpile.cache==0.6.5
dulwich==0.19.0
enum34==1.0.4
enum-compat==0.0.2
eventlet==0.20.0
eventlet==0.18.2
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
@ -42,20 +43,20 @@ hacking==0.12.0
idna==2.6
imagesize==1.0.0
ipaddress==1.0.19
iso8601==0.1.12
iso8601==0.1.11
Jinja2==2.10
jmespath==0.9.3
jsonpatch==1.21
jsonpatch==1.16
jsonpointer==2.0
jsonschema==2.6.0
keystoneauth1==3.4.0
keystonemiddleware==4.21.0
keystonemiddleware==4.17.0
kombu==4.1.0
kubernetes==5.0.0
linecache2==1.0.0
logutils==0.3.5
Mako==1.0.7
marathon==0.9.3
marathon==0.8.6
MarkupSafe==1.0
mccabe==0.2.1
mock==2.0.0
@ -63,13 +64,13 @@ monotonic==1.4
mox3==0.25.0
msgpack==0.5.6
munch==2.2.0
netaddr==0.7.19
netaddr==0.7.18
netifaces==0.10.6
networkx==1.11
oauthlib==2.0.6
openstackdocstheme==1.20.0
openstackdocstheme==1.18.1
openstacksdk==0.12.0
os-api-ref==1.5.0
os-api-ref==1.4.0
os-client-config==1.29.0
os-service-types==1.2.0
os-testr==1.0.0
@ -77,33 +78,33 @@ osc-lib==1.10.0
oslo.cache==1.29.0
oslo.concurrency==3.26.0
oslo.config==5.2.0
oslo.context==2.20.0
oslo.db==4.35.0
oslo.i18n==3.20.0
oslo.log==3.37.0
oslo.messaging==5.36.0
oslo.middleware==3.35.0
oslo.policy==1.34.0
oslo.reports==1.27.0
oslo.serialization==2.25.0
oslo.service==1.30.0
oslo.utils==3.36.0
oslo.versionedobjects==1.32.0
oslotest==3.3.0
osprofiler==2.0.0
oslo.context==2.19.2
oslo.db==4.27.0
oslo.i18n==3.15.3
oslo.log==3.36.0
oslo.messaging==5.29.0
oslo.middleware==3.31.0
oslo.policy==1.30.0
oslo.reports==1.18.0
oslo.serialization==2.18.0
oslo.service==1.24.0
oslo.utils==3.33.0
oslo.versionedobjects==1.31.2
oslotest==3.2.0
osprofiler==1.4.0
packaging==17.1
Paste==2.0.3
PasteDeploy==1.5.2
pbr==3.1.1
pecan==1.2.1
pbr==2.0.0
pecan==1.0.0
pep8==1.5.7
pika==0.10.0
pika-pool==0.1.3
pika==0.10.0
prettytable==0.7.2
psutil==5.4.3
pyasn1==0.4.2
pyasn1-modules==0.2.1
pycadf==2.7.0
pyasn1==0.4.2
pycadf==1.1.0
pycparser==2.18
pyflakes==0.8.1
Pygments==2.2.0
@ -111,49 +112,50 @@ pyinotify==0.9.6
pyOpenSSL==17.5.0
pyparsing==2.2.0
pyperclip==1.6.0
python-barbicanclient==4.6.0
python-barbicanclient==4.5.2
python-dateutil==2.7.0
python-editor==1.0.3
python-glanceclient==2.9.1
python-heatclient==1.14.0
python-keystoneclient==3.15.0
python-glanceclient==2.8.0
python-heatclient==1.10.0
python-keystoneclient==3.8.0
python-mimeparse==1.6.0
python-neutronclient==6.7.0
python-novaclient==10.1.0
python-subunit==1.2.0
python-novaclient==9.1.0
python-subunit==1.0.0
python-swiftclient==3.5.0
pytz==2018.3
pytz==2013.6
PyYAML==3.12
reno==2.7.0
reno==2.5.0
repoze.lru==0.7
requests==2.18.4
requests-oauthlib==0.8.0
requests-toolbelt==0.8.0
requests==2.14.2
requestsexceptions==1.4.0
restructuredtext-lint==1.1.3
rfc3986==1.1.0
Routes==2.4.1
rsa==3.4.2
setuptools==21.0.0
simplegeneric==0.8.1
simplejson==3.13.2
six==1.11.0
six==1.10.0
smmap2==2.0.3
snowballstemmer==1.2.1
Sphinx==1.6.5
Sphinx==1.6.2
sphinxcontrib-websupport==1.0.1
SQLAlchemy==1.2.5
sqlalchemy-migrate==0.11.0
SQLAlchemy==1.0.10
sqlparse==0.2.4
statsd==3.2.2
stestr==2.0.0
stevedore==1.28.0
taskflow==3.1.0
stevedore==1.20.0
taskflow==2.16.0
Tempita==0.5.2
tenacity==4.9.0
testrepository==0.0.20
testrepository==0.0.18
testresources==2.0.1
testscenarios==0.5.0
testtools==2.3.0
testscenarios==0.4
testtools==2.2.0
traceback2==1.4.0
unittest2==1.1.0
urllib3==1.22
@ -161,9 +163,9 @@ vine==1.1.4
voluptuous==0.11.1
waitress==1.1.0
warlock==1.3.0
WebOb==1.7.4
WebOb==1.7.1
websocket-client==0.47.0
WebTest==2.0.29
Werkzeug==0.14.1
Werkzeug==0.9
wrapt==1.10.11
WSME==0.9.2
WSME==0.8.0

2
requirements.txt

@ -15,7 +15,7 @@ cliff!=2.9.0,>=2.8.0 # Apache-2.0
decorator>=3.4.0 # BSD
docker>=2.4.2 # Apache-2.0
enum34>=1.0.4;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
iso8601>=0.1.11 # MIT
jsonpatch!=1.20,>=1.16 # BSD
keystoneauth1>=3.4.0 # Apache-2.0

Loading…
Cancel
Save