Browse Source

Bump up prometheus operator chart to 8.2.2

Without this, deployment fails on 1.16.x due to deprecated APIs.

Story: 2006853
Task: 37577

Change-Id: I6dd1fa4649bc2b8d06abd28ae3aa9259b384d171
changes/43/695443/8
Bharat Kunwar 3 years ago
parent
commit
4eff195cc0
  1. 4
      magnum/drivers/common/templates/kubernetes/helm/prometheus-operator.sh
  2. 2
      magnum/drivers/k8s_fedora_atomic_v1/templates/kubecluster.yaml
  3. 2
      magnum/drivers/k8s_fedora_coreos_v1/templates/kubecluster.yaml
  4. 5
      releasenotes/notes/prometheus-operator-compatible-with-k8s-1-16-f8be99cf527075b8.yaml

4
magnum/drivers/common/templates/kubernetes/helm/prometheus-operator.sh

@ -10,8 +10,6 @@ printf "Starting to run ${step}\n"
### Configuration
###############################################################################
CHART_NAME="prometheus-operator"
CHART_VERSION=${PROMETHEUS_OPERATOR_CHART_TAG:-5.12.3}
if [ "$(echo ${MONITORING_ENABLED} | tr '[:upper:]' '[:lower:]')" = "true" ]; then
@ -64,7 +62,7 @@ data:
exit 0
else
# TODO: Set namespace to monitoring. This is needed as the Kubernetes default priorityClass can only be used in NS kube-system
helm install stable/${CHART_NAME} --namespace kube-system --name ${CHART_NAME} --version v${CHART_VERSION} --values /opt/magnum/install-${CHART_NAME}-values.yaml
helm install stable/${CHART_NAME} --namespace kube-system --name ${CHART_NAME} --version ${PROMETHEUS_OPERATOR_CHART_TAG} --values /opt/magnum/install-${CHART_NAME}-values.yaml
fi
install-${CHART_NAME}-values.yaml: |

2
magnum/drivers/k8s_fedora_atomic_v1/templates/kubecluster.yaml

@ -664,7 +664,7 @@ parameters:
prometheus_operator_chart_tag:
type: string
description: The stable/prometheus-operator chart version to use.
default: 5.12.3
default: v8.2.2
project_id:
type: string

2
magnum/drivers/k8s_fedora_coreos_v1/templates/kubecluster.yaml

@ -664,7 +664,7 @@ parameters:
prometheus_operator_chart_tag:
type: string
description: The stable/prometheus-operator chart version to use.
default: 5.12.3
default: v8.2.2
project_id:
type: string

5
releasenotes/notes/prometheus-operator-compatible-with-k8s-1-16-f8be99cf527075b8.yaml

@ -0,0 +1,5 @@
---
fixes:
- |
Bump up prometheus operator chart version to 8.2.2 so that it is compatible
with k8s 1.16.x.
Loading…
Cancel
Save