Browse Source

Requirements List Updates

Added comments to indicate which licenses apply to each.

Change-Id: Id2aa31736b4eb602042e648207cad5480b7a2de1
Closes-bug: 1427966
changes/75/161075/2
Adrian Otto 7 years ago
parent
commit
5f5bdb851a
  1. 44
      requirements.txt
  2. 26
      test-requirements.txt

44
requirements.txt

@ -2,26 +2,26 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=0.6,!=0.7,<1.0
Babel>=1.3
requests>=2.2.0,!=2.4.0
pbr>=0.6,!=0.7,<1.0 # Apache-2.0
Babel>=1.3 # MIT
requests>=2.2.0,!=2.4.0 # Apache-2.0
oslo.concurrency>=1.4.1 # Apache-2.0
oslo.config>=1.6.0
oslo.context>=0.1.0 # Apache-2.0
oslo.db>=1.4.1 # Apache-2.0
oslo.messaging>=1.6.0
oslo.serialization>=1.2.0 # Apache-2.0
oslo.utils>=1.2.0 # Apache-2.0
paramiko>=1.13.0
pecan>=0.8.0
keystonemiddleware>=1.0.0
oslo.i18n>=1.3.0 # Apache-2.0
python-heatclient>=0.2.9
python-keystoneclient>=1.1.0
python-kubernetes>=0.2
six>=1.7.0
SQLAlchemy>=0.9.7,<=0.9.99
WSME>=0.6
docker-py>=0.5.1
jsonpatch>=1.1
oslo.concurrency>=1.4.1 # Apache-2.0
oslo.config>=1.6.0 # Apache-2.0
oslo.context>=0.1.0 # Apache-2.0
oslo.db>=1.4.1 # Apache-2.0
oslo.messaging>=1.6.0 # Apache-2.0
oslo.serialization>=1.2.0 # Apache-2.0
oslo.utils>=1.2.0 # Apache-2.0
paramiko>=1.13.0 # LGPL
pecan>=0.8.0 # BSD
keystonemiddleware>=1.0.0 # Apache-2.0
oslo.i18n>=1.3.0 # Apache-2.0
python-heatclient>=0.2.9 # Apache-2.0
python-keystoneclient>=1.1.0 # Apache-2.0
python-kubernetes>=0.2 # Apache-2.0
six>=1.7.0 # MIT
SQLAlchemy>=0.9.7,<=0.9.99 # MIT
WSME>=0.6 # MIT
docker-py>=0.5.1 # Apache-2.0
jsonpatch>=1.1 # Modified BSD http://tinyurl.com/kghfvjw

26
test-requirements.txt

@ -2,17 +2,17 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking<0.11,>=0.10.0
hacking<0.11,>=0.10.0 # Apache-2.0
coverage>=3.6
discover
fixtures>=0.3.14
mock>=1.0
nose
python-subunit>=0.0.18
sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
oslosphinx>=2.2.0
oslotest>=1.2.0
testrepository>=0.0.18
testscenarios>=0.4
testtools>=0.9.36,!=1.2.0
coverage>=3.6 # BSD
discover # BSD
fixtures>=0.3.14 # Apache-2.0
mock>=1.0 # BSD
nose # LGPL
python-subunit>=0.0.18 # Apache-2.0 or BSD 3-clause
sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3 # BSD
oslosphinx>=2.2.0 # Apache-2.0
oslotest>=1.2.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0
testscenarios>=0.4 # Apache-2.0 or BSD 3-clause
testtools>=0.9.36,!=1.2.0 # MIT
Loading…
Cancel
Save