Browse Source

Use --containerized flag to support 1.{13,14,15}.x in Atomic

The flag has been removed in Kubernetes version 1.16.x for which users
should use Podman but to continue to use Fedora Atomic without
use_podman=true which means using Docker 1.13.x, ServiceAccount tokens
cannot be propagated without using the --containerized flag when
use_podman=false.

This flag should not have been removed in
I3efd4e55e885b95721f13279b44dc1246e2fd2e4.

Story: 2006846
Task: 37434

Change-Id: I5ccef63de928ff01d10dc4cc500d0e1583eb0378
changes/15/695415/6
Bharat Kunwar 2 weeks ago
parent
commit
8f2a324984
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      dockerfiles/kubernetes-kubelet/launch.sh

+ 1
- 1
dockerfiles/kubernetes-kubelet/launch.sh View File

@@ -11,4 +11,4 @@ ARGS=$(echo $ARGS | sed s/--cadvisor-port=0//)
ARGS=$(echo $ARGS | sed s/--require-kubeconfig//)
ARGS=$(echo $ARGS | sed s/node-role/node/)

exec /hyperkube kubelet $ARGS
exec /hyperkube kubelet $ARGS --containerized

Loading…
Cancel
Save