Add Cinder-API-ver to k8s-cloud-provider config

Explicit API-version is required when communicating with cinder, since
kubernetes expects a return 200 but receives 300 wen version is not
specified.

Change-Id: I1202d85f8029a078c099eee105b421c9660393fc
Closes-Bug: #1704410
changes/70/483970/1
Markus Sommer 5 years ago
parent 4e2dc3e590
commit 94d93177db
  1. 2
      magnum/drivers/common/templates/kubernetes/fragments/write-kube-os-config.sh

@ -18,4 +18,6 @@ create-monitor=yes
monitor-delay=1m
monitor-timeout=30s
monitor-max-retries=3
[BlockStorage]
bs-version=v2
EOF

Loading…
Cancel
Save