Browse Source

k8s_fedora: Bump up default kube_tag to v1.15.7

Also bump up cloud_provider_tag to v1.15.0.

This is the common supported version in Fedora Atomic (now EOL) when
`use_podman=true` label is not supplied.

Task: 37817
Story: 2005380

Change-Id: I4afaf159eaf2d2ff75bd3abec4137257e0daa8f2
Signed-off-by: Bharat Kunwar <brtknr@bath.edu>
changes/82/699182/2
Bharat Kunwar 3 years ago
parent
commit
9e3be39dd5
  1. 1
      doc/source/user/index.rst
  2. 10
      magnum/drivers/k8s_fedora_atomic_v1/templates/kubecluster.yaml
  3. 10
      magnum/drivers/k8s_fedora_coreos_v1/templates/kubecluster.yaml

1
doc/source/user/index.rst

@ -1216,6 +1216,7 @@ _`cloud_provider_tag`
the cloud-provider. The images are hosted `here
<https://hub.docker.com/r/k8scloudprovider/openstack-cloud-controller-manager/tags/>`_.
Stein default: v0.2.0
Train default: v1.15.0
_`etcd_tag`
This label allows users to select `a specific etcd version,

10
magnum/drivers/k8s_fedora_atomic_v1/templates/kubecluster.yaml

@ -432,17 +432,17 @@ parameters:
kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
master_kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
minion_kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
# FIXME update cloud_provider_tag when a fix for PVC is released
# https://github.com/kubernetes/cloud-provider-openstack/pull/405
@ -451,7 +451,7 @@ parameters:
description:
tag of the kubernetes/cloud-provider-openstack
https://hub.docker.com/r/k8scloudprovider/openstack-cloud-controller-manager/tags/
default: v1.14.0
default: v1.15.0
cloud_provider_enabled:
type: boolean
@ -480,7 +480,7 @@ parameters:
kube_version:
type: string
description: version of kubernetes used for kubernetes cluster
default: v1.14.3
default: v1.15.7
kube_dashboard_version:
type: string

10
magnum/drivers/k8s_fedora_coreos_v1/templates/kubecluster.yaml

@ -432,17 +432,17 @@ parameters:
kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
master_kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
minion_kube_tag:
type: string
description: tag of the k8s containers used to provision the kubernetes cluster
default: v1.14.3
default: v1.15.7
# FIXME update cloud_provider_tag when a fix for PVC is released
# https://github.com/kubernetes/cloud-provider-openstack/pull/405
@ -451,7 +451,7 @@ parameters:
description:
tag of the kubernetes/cloud-provider-openstack
https://hub.docker.com/r/k8scloudprovider/openstack-cloud-controller-manager/tags/
default: v1.14.0
default: v1.15.0
cloud_provider_enabled:
type: boolean
@ -480,7 +480,7 @@ parameters:
kube_version:
type: string
description: version of kubernetes used for kubernetes cluster
default: v1.14.3
default: v1.15.7
kube_dashboard_version:
type: string

Loading…
Cancel
Save