Use keystone v2.0 in gates

There was a recent patch to devstack that defaults all services
to use keystone v3.  We are still on keystone v2 in our gates so
we need to explicitly update back to v2.0

Closes-Bug: 1539764

Change-Id: I1fbe128f64e543973bd47f0ca2e5535453ad9186
changes/39/274239/1
dimtruck 7 years ago
parent 104d225466
commit ff3ec16ca7
  1. 5
      magnum/tests/contrib/post_test_hook.sh

@ -87,6 +87,11 @@ function add_flavor {
unset OS_AUTH_TYPE
popd
# Due to keystone defaulting everything to v3, we need to update to make func tests
# work in our gates back to v2
export OS_AUTH_URL=http://127.0.0.1:5000/v2.0
export OS_IDENTITY_API_VERSION=2.0
# Create magnum specific flavor for use in functional tests.
echo_summary "Create a flavor"
nova flavor-create m1.magnum 100 1024 8 1

Loading…
Cancel
Save