You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
magnum/requirements.txt

54 lines
1.4 KiB

# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
# Despite above warning added by global sync process, please use
# ascii betical order.
Babel>=1.3
PrettyTable<0.8,>=0.7
PyYAML>=3.1.0
SQLAlchemy<1.1.0,>=0.9.9
WSME>=0.8
WebOb>=1.2.3
alembic>=0.8.0
decorator>=3.4.0
docker-py>=1.4.0 # Apache-2.0
enum34;python_version=='2.7' or python_version=='2.6'
eventlet>=0.17.4
greenlet>=0.3.2
iso8601>=0.1.9
jsonpatch>=1.1
keystonemiddleware>=4.0.0
netaddr!=0.7.16,>=0.7.12
oslo.concurrency>=2.3.0 # Apache-2.0
oslo.config>=2.7.0 # Apache-2.0
oslo.context>=0.2.0 # Apache-2.0
oslo.db>=4.1.0 # Apache-2.0
oslo.i18n>=1.5.0 # Apache-2.0
oslo.log>=1.12.0 # Apache-2.0
oslo.messaging!=2.8.0,!=3.1.0,>2.6.1 # Apache-2.0
oslo.middleware>=3.0.0 # Apache-2.0
oslo.policy>=0.5.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.service>=1.0.0 # Apache-2.0
oslo.utils>=3.2.0 # Apache-2.0
oslo.versionedobjects>=0.13.0
oslo.reports>=0.6.0 # Apache-2.0
paramiko>=1.13.0
pbr>=1.6
pecan>=1.0.0
python-barbicanclient>=3.3.0
python-glanceclient>=1.2.0
python-heatclient>=0.6.0
python-neutronclient>=2.6.0
python-novaclient!=2.33.0,>=2.29.0
python-keystoneclient!=1.8.0,>=1.6.0
requests!=2.9.0,>=2.8.1
setuptools>=16.0
six>=1.9.0
stevedore>=1.5.0 # Apache-2.0
taskflow>=1.16.0
cryptography>=1.0 # Apache-2.0
urllib3>=1.8.3