Container Infrastructure Management Service for OpenStack
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

requirements.txt 2.0KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # The order of packages is significant, because pip processes them in the order
  2. # of appearance. Changing the order has an impact on the overall integration
  3. # process, which may cause wedges in the gate later.
  4. # Despite above warning added by global sync process, please use
  5. # ascii betical order.
  6. Babel!=2.4.0,>=2.3.4 # BSD
  7. PyYAML>=3.10 # MIT
  8. SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT
  9. WSME>=0.8 # MIT
  10. WebOb>=1.7.1 # MIT
  11. alembic>=0.8.10 # MIT
  12. cliff>=2.8.0 # Apache-2.0
  13. decorator>=3.4.0 # BSD
  14. docker>=2.0.0 # Apache-2.0
  15. enum34;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
  16. eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
  17. iso8601>=0.1.11 # MIT
  18. jsonpatch>=1.1 # BSD
  19. keystoneauth1>=3.1.0 # Apache-2.0
  20. keystonemiddleware>=4.12.0 # Apache-2.0
  21. kubernetes>=1.0.0 # Apache-2.0
  22. marathon>=0.8.6 # MIT
  23. netaddr!=0.7.16,>=0.7.13 # BSD
  24. oslo.concurrency>=3.8.0 # Apache-2.0
  25. oslo.config!=4.3.0,!=4.4.0,>=4.0.0 # Apache-2.0
  26. oslo.context>=2.14.0 # Apache-2.0
  27. oslo.db>=4.24.0 # Apache-2.0
  28. oslo.i18n!=3.15.2,>=2.1.0 # Apache-2.0
  29. oslo.log>=3.22.0 # Apache-2.0
  30. oslo.messaging!=5.25.0,>=5.24.2 # Apache-2.0
  31. oslo.middleware>=3.27.0 # Apache-2.0
  32. oslo.policy>=1.23.0 # Apache-2.0
  33. oslo.serialization!=2.19.1,>=1.10.0 # Apache-2.0
  34. oslo.service>=1.10.0 # Apache-2.0
  35. oslo.utils>=3.20.0 # Apache-2.0
  36. oslo.versionedobjects>=1.17.0 # Apache-2.0
  37. oslo.reports>=0.6.0 # Apache-2.0
  38. pbr!=2.1.0,>=2.0.0 # Apache-2.0
  39. pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0 # BSD
  40. pycadf!=2.0.0,>=1.1.0 # Apache-2.0
  41. python-barbicanclient!=4.5.0,!=4.5.1,>=4.0.0 # Apache-2.0
  42. python-glanceclient>=2.8.0 # Apache-2.0
  43. python-heatclient>=1.6.1 # Apache-2.0
  44. python-neutronclient>=6.3.0 # Apache-2.0
  45. python-novaclient>=9.0.0 # Apache-2.0
  46. python-keystoneclient>=3.8.0 # Apache-2.0
  47. requests>=2.14.2 # Apache-2.0
  48. setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,!=36.2.0,>=16.0 # PSF/ZPL
  49. six>=1.9.0 # MIT
  50. stevedore>=1.20.0 # Apache-2.0
  51. taskflow>=2.7.0 # Apache-2.0
  52. cryptography!=2.0,>=1.6 # BSD/Apache-2.0
  53. Werkzeug>=0.7 # BSD License