Switch to newer openstackdocstheme version

Switch to openstackdocstheme 2.2.1 version. Using
this version will allow especially:
* Linking from HTML to PDF document
* Allow parallel building of documents
* Fix some rendering problems

Update Sphinx version as well.

Change pygments_style to 'native' since old theme version always used
'native' and the theme now respects the setting and using 'sphinx' can
lead to some strange rendering.

openstackdocstheme renames some variables, so follow the renames
before the next release removes them. A couple of variables are also
not needed anymore, remove them.

See also
http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014971.html

Change-Id: Id7a2401cd31c0b05812a76d2cc5f1e6a014cb510
changes/22/732022/1
Andreas Jaeger 3 years ago
parent f75519fba5
commit e5ae79051f

@ -27,9 +27,9 @@ extensions = [
]
# openstackdocstheme options
repository_name = 'openstack/manila-image-elements'
bug_project = 'manila-image-elements'
bug_tag = 'docs'
openstackdocs_repo_name = 'openstack/manila-image-elements'
openstackdocs_bug_project = 'manila-image-elements'
openstackdocs_bug_tag = 'docs'
# autodoc generation is a bit aggressive and a nuisance when doing heavy
# text edit cycles.
@ -53,7 +53,7 @@ add_function_parentheses = True
add_module_names = True
# The name of the Pygments (syntax highlighting) style to use.
pygments_style = 'sphinx'
pygments_style = 'native'
# -- Options for HTML output --------------------------------------------------

@ -13,7 +13,7 @@ Jinja2==2.10
MarkupSafe==1.0
mccabe==0.2.1
networkx==1.11
openstackdocstheme==1.31.2
openstackdocstheme==2.2.1
pbr==2.0.0
Pygments==2.2.0
pytz==2018.3
@ -21,7 +21,7 @@ PyYAML==3.12
requests==2.18.4
six==1.11.0
snowballstemmer==1.2.1
Sphinx==1.6.2
Sphinx==2.0.0
sphinxcontrib-websupport==1.0.1
stevedore==1.28.0
urllib3==1.22

@ -6,5 +6,5 @@ bashate>=0.5.1 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
docutils>=0.11 # OSI-Approved Open Source, Public Domain
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
openstackdocstheme>=1.31.2 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.2.1 # Apache-2.0

Loading…
Cancel
Save