Browse Source

set basepython for pylint tox env

to python2.7 so that running locally will succeed
and the results will match those for the gate
pylint job.

Partial-Bug: #1673824

Change-Id: I6c45a32ba8e77c35403357b0100379bb536a36b3
Tom Barron 2 years ago
parent
commit
7dfd141915
1 changed files with 2 additions and 0 deletions
  1. 2
    0
      tox.ini

+ 2
- 0
tox.ini View File

@@ -77,12 +77,14 @@ commands =
77 77
   {toxinidir}/tools/fast8.sh
78 78
 
79 79
 [testenv:pylint]
80
+basepython = python2.7
80 81
 deps = -r{toxinidir}/requirements.txt
81 82
        pylint==0.26.0
82 83
 whitelist_externals = bash
83 84
 commands = bash tools/lintstack.sh
84 85
 
85 86
 [testenv:lint]
87
+basepython = python2.7
86 88
 deps = -r{toxinidir}/requirements.txt
87 89
        pylint==0.26.0
88 90
 commands = python tools/lintstack.py check

Loading…
Cancel
Save