Browse Source

Use psycopg2-binary for test-requirements

In order to run PostgreSQL tests, we need to have the PostgreSQL
dependency available on the system.  We currently use the dependency
which forces building the Python package from source.  That makes
running the tests locally non-trivial and requiring the installation
of packages locally.

This patch moves that dependency to the binary one so that we can
simply deploy a binary artifact during CI, which simplifies the
abilitiy to run those tests.

Change-Id: I33369712370b86feca843f118f35063d0993adcb
(cherry picked from commit 3e82f118b7)
changes/53/706753/1
Mohammed Naser 2 weeks ago
parent
commit
ab5765d917
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 1
- 1
lower-constraints.txt View File

@@ -89,7 +89,7 @@ pika==0.10.0
pika-pool==0.1.3
prettytable==0.7.2
psutil==5.4.3
psycopg2==2.6.2
psycopg2-binary==2.6.2
pyasn1==0.4.2
pycadf==2.7.0
pycparser==2.18

+ 1
- 1
test-requirements.txt View File

@@ -17,7 +17,7 @@ oslotest>=3.2.0 # Apache-2.0
# by oslo_db lib for running MySQL and PostgreSQL DB migration tests.
# See https://docs.openstack.org/oslo.db/latest/contributor/index.html#how-to-run-unit-tests
PyMySQL>=0.7.6 # MIT License
psycopg2>=2.6.2 # LGPL/ZPL
psycopg2-binary>=2.6.2 # LGPL/ZPL

requests-mock>=1.2.0 # Apache-2.0
os-api-ref>=1.4.0 # Apache-2.0

Loading…
Cancel
Save