Browse Source

change tox envlist from 3.5 to 3

base python version is 3, not 3.5 and
python 3.5 is not installed in some current
distros so running 'tox' locally fails.

Change-Id: Ie2449a433e07f4cafb55fe1db247ba9f854cef97
Tom Barron 6 months ago
parent
commit
e62f1f4f9c
1 changed files with 3 additions and 3 deletions
  1. 3
    3
      tox.ini

+ 3
- 3
tox.ini View File

@@ -1,7 +1,7 @@
1 1
 [tox]
2 2
 minversion = 2.0
3 3
 skipsdist = True
4
-envlist = py35,py27,pep8
4
+envlist = py3,py27,pep8
5 5
 
6 6
 [testenv]
7 7
 setenv = VIRTUAL_ENV={envdir}
@@ -35,8 +35,8 @@ commands = oslo_debug_helper {posargs}
35 35
 basepython = python2.7
36 36
 commands = oslo_debug_helper {posargs}
37 37
 
38
-[testenv:debug-py35]
39
-basepython = python3.5
38
+[testenv:debug-py3]
39
+basepython = python3
40 40
 commands = oslo_debug_helper {posargs}
41 41
 
42 42
 [testenv:pep8]

Loading…
Cancel
Save