Update python testing as per zed cycle testing runtime

In Zed cycle, we have dropped the python 3.6/3.7[1] testing
and its support. Add release notes and update the python
classifier for the same.

[1] https://governance.openstack.org/tc/reference/runtimes/zed.html

Co-Authored-By: Ghanshyam Mann <gmann@ghanshyammann.com>
Change-Id: I6e78e80c2e5c4e5a39bd3c3dfbfddaf3973abb77
changes/43/849243/2
Takashi Kajinami 7 months ago
parent 2980dfc44f
commit 4afa41b90f

@ -2,4 +2,4 @@
templates:
- horizon-non-primary-django-jobs
- check-requirements
- openstack-python3-xena-jobs
- openstack-python3-zed-jobs

@ -0,0 +1,5 @@
---
upgrade:
- |
Python 3.6 & 3.7 support has been dropped. The minimum version of Python now
supported is Python 3.8.

@ -3,12 +3,12 @@ name = mistral-dashboard
summary = Mistral dashboard
description_file = README.rst
license = Apache License, Version 2.0
python_requires = >=3.8
classifiers =
Programming Language :: Python
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
Environment :: OpenStack
Intended Audience :: Information Technology
Intended Audience :: System Administrators

Loading…
Cancel
Save