Browse Source

Sync Sphinx requirement

1. Sync sphinx dependency with global requirements. It caps python 2 since
sphinx 2.0 no longer supports Python 2.7.
2. Update some URLs to latest
3. Update the UPPER_CONSTRAINTS_FILE for tox[1]

[1]: refer to  http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006478.html

Change-Id: Id095cbd60f5a11f25a64f37b18393afbd4b4262c
changes/06/666306/2
jacky06 2 years ago
parent
commit
5f68888dce
4 changed files with 6 additions and 5 deletions
  1. +2
    -2
      CONTRIBUTING.rst
  2. +1
    -1
      README.rst
  3. +2
    -1
      test-requirements.txt
  4. +1
    -1
      tox.ini

+ 2
- 2
CONTRIBUTING.rst View File

@ -1,14 +1,14 @@
If you would like to contribute to the development of OpenStack, you must
follow the steps in this page:
http://docs.openstack.org/infra/manual/developers.html
https://docs.openstack.org/infra/manual/developers.html
If you already have a good understanding of how the system works and your
OpenStack accounts are set up, you can skip to the development workflow
section of this documentation to learn how changes to OpenStack should be
submitted for review via the Gerrit tool:
http://docs.openstack.org/infra/manual/developers.html#development-workflow
https://docs.openstack.org/infra/manual/developers.html#development-workflow
Pull requests submitted through GitHub will be ignored.


+ 1
- 1
README.rst View File

@ -17,7 +17,7 @@ contains the public interfaces for 3rd party integration (e.g. Actions API, YAQL
functions API, etc.)
If you want to use OpenStack in your custom actions or functions, you will also
need to use http://opendev.org/openstack/mistral-extra.
need to use https://opendev.org/openstack/mistral-extra.
* Free software: Apache license
* Documentation: https://docs.openstack.org/mistral/latest/


+ 2
- 1
test-requirements.txt View File

@ -4,7 +4,8 @@
hacking>=1.1.0,<1.2.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
stestr>=2.0.0 # Apache-2.0


+ 1
- 1
tox.ini View File

@ -11,7 +11,7 @@ setenv = VIRTUAL_ENV={envdir}
PYTHONWARNINGS=default::DeprecationWarning
passenv = http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://opendev.org/openstack/requirements/raw/branch/master/upper-constraints.txt}
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/requirements.txt
commands =


Loading…
Cancel
Save