Browse Source

Update requirements manually

The global requirments sync for this repo fails since it lists
packages that are not in the global list. Manually sync
requirements.

Failure log from requirements sync:
http://logs.openstack.org/d8/d89aad257d/post/propose-update-requirements/15a7777/job-output.txt.gz#_2018-01-31_06_57_19_908947

Errors are:
'jira' is not in global-requirements.txt or blacklist.txt

Change-Id: If85ee1bf750d310f7a3d2f52c6fd224a9ed822a2
Andreas Jaeger 1 year ago
parent
commit
99796ebb7f
3 changed files with 14 additions and 14 deletions
  1. 6
    6
      requirements.txt
  2. 2
    2
      setup.cfg
  3. 6
    6
      test-requirements.txt

+ 6
- 6
requirements.txt View File

@@ -1,12 +1,12 @@
1 1
 # The order of packages is significant, because pip processes them in the order
2 2
 # of appearance. Changing the order has an impact on the overall integration
3 3
 # process, which may cause wedges in the gate later.
4
-pbr>=2.0.0,!=2.1.0  # Apache-2.0
5
-debtcollector>=1.2.0  # Apache-2.0
4
+pbr!=2.1.0,>=2.0.0 # Apache-2.0
5
+debtcollector>=1.2.0 # Apache-2.0
6 6
 monasca-statsd>=1.1.0 # Apache-2.0
7 7
 requests>=2.14.2 # Apache-2.0
8
-PyYAML>=3.10  # MIT
9
-six>=1.9.0 # MIT
8
+PyYAML>=3.10 # MIT
9
+six>=1.10.0 # MIT
10 10
 monasca-common>=1.4.0 # Apache-2.0
11
-oslo.config>=4.6.0  # Apache-2.0
12
-oslo.log>=3.30.0  # Apache-2.0
11
+oslo.config>=5.1.0 # Apache-2.0
12
+oslo.log>=3.36.0 # Apache-2.0

+ 2
- 2
setup.cfg View File

@@ -35,5 +35,5 @@ universal = 1
35 35
 
36 36
 [extras]
37 37
 jira_plugin =
38
-    jira
39
-    jinja2
38
+  jira
39
+  Jinja2!=2.9.0,!=2.9.1,!=2.9.2,!=2.9.3,!=2.9.4,>=2.8 # BSD License (3 clause)

+ 6
- 6
test-requirements.txt View File

@@ -4,14 +4,14 @@
4 4
 # Hacking already pins down pep8, pyflakes and flake8
5 5
 
6 6
 bandit>=1.1.0 # Apache-2.0
7
-Babel>=2.3.4,!=2.4.0  # BSD
7
+Babel!=2.4.0,>=2.3.4 # BSD
8 8
 hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
9
-coverage>=4.0,!=4.4  # Apache-2.0
10
-mock>=2.0.0  # BSD
11
-funcsigs>=1.0.0;python_version=='2.7' or python_version=='2.6'  # Apache-2.0
9
+coverage!=4.4,>=4.0 # Apache-2.0
10
+mock>=2.0.0 # BSD
11
+funcsigs>=1.0.0;python_version=='2.7' or python_version=='2.6' # Apache-2.0
12 12
 os-testr>=1.0.0 # Apache-2.0
13
-oslotest>=1.10.0 # Apache-2.0
13
+oslotest>=3.2.0 # Apache-2.0
14 14
 testrepository>=0.0.18 # Apache-2.0/BSD
15
-SQLAlchemy>=1.0.10,!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8  # MIT
15
+SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT
16 16
 PyMySQL>=0.7.6 # MIT License
17 17
 psycopg2>=2.6.2 # LGPL/ZPL

Loading…
Cancel
Save