Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg:
  * Wheel is not needed for python 3 only repo
  * Some other sections are obsolete
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: I95fb0ca759471f7ad7189a7d54c1dac2cc018fc4
changes/57/717557/1
Andreas Jaeger 3 years ago
parent 26844c1dd0
commit a2fcddc99b
  1. 16
      setup.cfg
  2. 9
      setup.py
  3. 2
      test-requirements.txt

@ -3,24 +3,23 @@ name = monasca-persister
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
summary = Moves metrics and alarm state transitions from the Message Queue to the Metrics and Alarms database.
python-requires = >=3.6
classifier=
Development Status :: 5 - Production/Stable
License :: OSI Approved :: Apache Software License
Topic :: System :: Monitoring
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
keywords = openstack monitoring storage
description-file = README.rst
home-page = https://github.com/openstack/monasca-persister
home-page = https://opendev.org/openstack/monasca-persister
license = Apache
[global]
setup-hooks =
pbr.hooks.setup_hook
[entry_points]
console_scripts =
monasca-persister = monasca_persister.persister:main
@ -37,8 +36,7 @@ data_files =
[extras]
influxdb =
influxdb!=5.2.0,!=5.2.1,!=5.2.2,!=5.2.3,>=2.9.2;python_version<'3.0' # MIT
influxdb>=2.9.2;python_version>='3.0' # MIT
influxdb>=2.9.2 # MIT
cassandra =
cassandra-driver>=3.11.0 # Apache-2.0
elasticsearch =
@ -46,7 +44,3 @@ elasticsearch =
[pbr]
autodoc_index_modules = True
[wheel]
universal = 1

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

@ -13,6 +13,6 @@ pycodestyle>=2.5.0 # MIT
cassandra-driver>=3.11.0
# release notes
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
reno>=2.5.0 # Apache-2.0
openstackdocstheme>=1.20.0 # Apache-2.0

Loading…
Cancel
Save