Browse Source

Remove explicit dependency on pep8/pyflakes

flake8 already pulls in the new dependency (pycodestyle and pyflakes)
in the right versions, so listing it explicitely is wrong and
unnecessary. flake8 2.5.5 depends on:
  'pep8 (>=1.5.7,!=1.6.0,!=1.6.1,!=1.6.2)',
  'pyflakes (<1.1,>=0.8.1)']

This seems to be from times where flake8 wasn't doing that before.

Change-Id: Ib145e2afa97f441c07fada9c30f0f0e2410870ae
Dirk Mueller 1 year ago
parent
commit
a331e6bc88
1 changed files with 1 additions and 3 deletions
  1. 1
    3
      test-requirements.txt

+ 1
- 3
test-requirements.txt View File

@@ -3,9 +3,7 @@
3 3
 # process, which may cause wedges in the gate later.
4 4
 # this file lists dependencies required for the testing of heat
5 5
 
6
-# Install bounded pep8/pyflakes first, then let flake8 install
7
-pep8==1.5.7 # MIT
8
-pyflakes==0.8.1 # MIT
6
+# Install flake8 first, it pulls in the right linter versions
9 7
 flake8<2.6.0,>=2.5.4 # MIT
10 8
 
11 9
 coverage!=4.4,>=4.0 # Apache-2.0

Loading…
Cancel
Save