Browse Source

Sync Sphinx requirement

Sync sphinx dependency with global requirements. It caps python 2 since
sphinx 2.0 no longer supports Python 2.7.

Change-Id: Ib934cd24f4af8440458f0d24df90b77e0a3040b5
changes/04/664504/1
ljhuang 6 months ago
parent
commit
a1d16fc411
1 changed files with 2 additions and 1 deletions
  1. +2
    -1
      test-requirements.txt

+ 2
- 1
test-requirements.txt View File

@@ -6,7 +6,8 @@ hacking<0.13,>=0.12.0 # Apache-2.0

coverage!=4.4,>=4.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
oslotest>=3.2.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

Loading…
Cancel
Save