Browse Source

Fix lower-constraints

psycopg2 minimum version must be changed to 2.7.1, and due to pylint
incompatibility basepython for pep8 is changed to python2.

Closes-Bug: #1823145
Change-Id: Iff486d944815a6be84d05b49e2a96c49db6b2c4a
changes/23/701923/2
elajkat 1 month ago
parent
commit
18d1cf6928
3 changed files with 4 additions and 3 deletions
  1. +2
    -2
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt
  3. +1
    -0
      tox.ini

+ 2
- 2
lower-constraints.txt View File

@@ -106,7 +106,7 @@ Pint==0.5
positional==1.2.1
prettytable==0.7.2
psutil==3.2.2
psycopg2==2.6.2
psycopg2==2.7.1
pyasn1==0.1.8
pycadf==1.1.0
pycparser==2.18
@@ -151,7 +151,7 @@ Sphinx==1.6.5
sphinxcontrib-blockdiag==1.5.4
sphinxcontrib-seqdiag==0.8.4
sphinxcontrib-websupport==1.0.1
SQLAlchemy==1.0.10
SQLAlchemy==1.2.0
sqlalchemy-migrate==0.11.0
sqlparse==0.2.2
statsd==3.2.1

+ 1
- 1
test-requirements.txt View File

@@ -7,7 +7,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
django-nose>=1.4.4 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
psycopg2>=2.6.2 # LGPL/ZPL
psycopg2>=2.7.1 # LGPL/ZPL
PyMySQL>=0.7.6 # MIT License
WebOb>=1.7.1 # MIT
oslotest>=3.2.0 # Apache-2.0

+ 1
- 0
tox.ini View File

@@ -24,6 +24,7 @@ deps = -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/re
commands = sphinx-build -W -a -E -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html

[testenv:pep8]
basepython = python2
deps =
{[testenv]deps}
commands =

Loading…
Cancel
Save